WordPress.org

Make WordPress Core

Opened 8 days ago

Closed 8 days ago

Last modified 8 days ago

#54094 closed enhancement (duplicate)

Echo local wp-env URL when running env:start

Reported by: danfarrow Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: has-patch
Focuses: Cc:

Description

In an effort to make the wp-env tools a wee bit friendly to new devs I’ve added a console.log to echo the local URL when running env:start

http://127.0.0.1: is hard-coded, the port number is added using the variable process.env.LOCAL_PORT

On my machine the console output looks like this:

$ npm run env:start                                                      

> WordPress@5.9.0 env:start
> node ./tools/local-env/scripts/start.js

Starting wordpress-develop_mysql_1 ... done
Starting wordpress-develop_php_1   ... done
Starting wordpress-develop_wordpress-develop_1 ... done
-------------------------------------------
wp-env now running on http://127.0.0.1:8889
-------------------------------------------

Change History (2)

#1 follow-up: @mukesh27
8 days ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #54095.

#2 in reply to: ↑ 1 @danfarrow
8 days ago

Replying to mukesh27:

Duplicate of #54095.

I have no idea how I managed to post the same ticket twice - thank you for cleaning up!

Note: See TracTickets for help on using tickets.