WordPress.org

Make WordPress Core

Opened 6 weeks ago

Closed 6 weeks ago

#54108 closed enhancement (reported-upstream)

Dismiss Full Screen Editor Forever

Reported by: mitchellk Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0
Component: Editor Keywords:
Focuses: Cc:

Description

Gutenberg is great but I absolutely detest the Full Screen Editor taking over my screen. I find it a horrible visual disturbance for the way I work. I turn it off only to have it a week later turn itself back on. The same happens with the little "Gutenberg Blocks" guide that pops up whenever it chooses. Please guys, Gutenberg has been with us for some time already, kindly give your users options to turn off and disable things you keep shoving in our faces. This is becoming so common with WordPress and Woocommerce many new features with ZERO consideration of giving an OFF or DISMISS button.

Change History (1)

#1 @Clorith
6 weeks ago

  • Component changed from General to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed
  • Version changed from 5.8.1 to 5.0

This is an understandable point of frustration, and generally comes down to how browsers are handling the way the block editor stores editor settings per user.

There is al ongoing discussion on improving how this is handled at https://github.com/WordPress/gutenberg/issues/15105

Until such a time as the options are stored to the database, you may use a plugin to solve this on your own site as a temporary solution, for example https://wordpress.org/plugins/blockeditor-fullscreen-mode-control/

Since the issue is relating to the block-editor settings, and they have a ticket for discussing this, I am closing this one, and flagging that it is reported in the Gutenberg code repository instead.

Note: See TracTickets for help on using tickets.