WordPress.org

Make WordPress Core

Opened 4 weeks ago

Closed 4 weeks ago

Last modified 2 weeks ago

#54139 closed defect (bug) (invalid)

wordpress classic editor changes code and breaks code

Reported by: devrekli Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.8.1
Component: Editor Keywords:
Focuses: Cc:

Description

Hello. I saw that some pictures on website are wrong.

Example wrong image code

<img class="alignnone size-full wp-image-197" src="https://www.site.com/wp-content/uploads/dev.jpg" alt="" width="800" height="453">

The end of this code should be like this

/>

height="453" />

the editor is changing the image code and the images are giving an error.

When I add it for the first time, it does not give an error, after a certain time, an error occurs. This is so interesting.

I am using the classic editor.

add_filter('use_block_editor_for_post', 'return_false');

Then I tried the plugin but there was no solution.

watch please

https://youtu.be/L-fFRZxFKr8

Change History (4)

#1 @costdev
4 weeks ago

Hi @devrekli, thanks for raising this ticket. I'm having trouble reproducing the issue.

Have you tried disabling all plugins and switching to a default theme to see if this issue is resolved? If not, can you do that and let me know if you still encounter the issue?

#2 @devrekli
4 weeks ago

The problem is in the NextGEN Gallery plugin. sorry, delete topic please.

thanks

#3 @costdev
4 weeks ago

  • Resolution set to invalid
  • Status changed from new to closed

#4 @desrosj
2 weeks ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.