WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#54141 closed defect (bug) (invalid)

Trying to access array offset on value of type int wp-includes/formatting.php on line 884

Reported by: kientv Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: Formatting Keywords:
Focuses: administration Cc:

Description

I'm using WordPress 5.7.2 with PHP8.0, GCS plugin and Divi theme builder.
And this is my log when importing divi layout json pack:

2021/09/17 03:47:42 [error] 23#25: [ngx_pagespeed 1.13.35.2-0] Slow ReadFile operation on file /var/cache/ngx_pagespeed/v3/localhost/http,3A/,2Flocalhost/wp-content/themes/Divi/core/admin/css/version-rollback.css,3Fver=4.9.10,: 58.051ms; configure SlowFileLatencyUs to change threshold

127.0.0.1 -  17/Sep/2021:03:47:46 +0000 "GET /wp-admin/edit.php" 200
NOTICE: PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884
NOTICE: PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884
NOTICE: PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884
NOTICE: PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884
NOTICE: PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884
NOTICE: PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884
NOTICE: PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884
NOTICE: PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884
NOTICE: PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884
NOTICE: PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884
127.0.0.1 -  17/Sep/2021:03:48:09 +0000 "POST /wp-admin/admin-ajax.php" 200
2021/09/17 03:48:26 [error] 23#23: *56 FastCGI sent in stderr: "PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884PHP message: PHP Warning:  Trying to access array offset on value of type int in /var/www/html/wp-includes/formatting.php on line 884" while reading response header from upstream, client: 127.0.0.1, server: , request: "POST /wp-admin/admin-ajax.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "localhost", referrer: "http://localhost/wp-admin/edit.php?post_type=et_pb_layout"

Change History (2)

#1 @desrosj
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @kientv,

Welcome to Trac!

Even though the error specifically references a WordPress Core file, this issue is usually caused by a non-array value being passed to a function or filter. This issue will need to be reported to the plugin or theme responsible for the feature you were attempting to use.

I'm closing this as invalid, but only because there is nothing actionable on the WordPress Core side right now and that is the default ticket resolution.

#2 @SergeyBiryukov
3 months ago

  • Component changed from Administration to Formatting
Note: See TracTickets for help on using tickets.