WordPress.org

Make WordPress Core

Opened 4 weeks ago

Last modified 3 weeks ago

#54146 assigned defect (bug)

The extension "webp" is missing

Reported by: almendron Owned by: adamsilverstein
Milestone: 5.9 Priority: normal
Severity: normal Version: 5.8.1
Component: Media Keywords:
Focuses: Cc:

Description

File wp-includes/js/media-views.js
Line 3449

return /\.(jpe?g|png|gif)$/i.test( attachment.get('filename') );

File wp-includes/js/dist/block-editor.js
Line 26680

}) => /^image\/(?:jpe?g|png|gif)$/.test(type)); // Only process files if no HTML is present.

Line 30251

}) => /^image\/(?:jpe?g|png|gif)$/.test(type)).map(file => `<img src="${Object(external_wp_blob_["createBlobURL"])(file)}">`).join('');

File wp-includes/js/plupload/wp-plupload.js
Line 379

mage = /(?:jpe?g|png|gif)$/i.exec( file.name );

Change History (3)

#1 @adamsilverstein
3 weeks ago

  • Owner set to adamsilverstein
  • Status changed from new to assigned

Hi @almendron - thanks for the bug report.

Did you notice any effect of the missing webp extension in each of these cases? I agree thee likely need updating, however it would be good to understand what each does so we can document and test that the change fixes an issue.

#2 @almendron
3 weeks ago

File wp-includes/js/media-views.js: #53917

Rest of cases: not verified.

Last edited 3 weeks ago by SergeyBiryukov (previous) (diff)

#3 @SergeyBiryukov
3 weeks ago

  • Milestone changed from Awaiting Review to 5.9
Note: See TracTickets for help on using tickets.