WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#5416 closed defect (bug) (fixed)

WP req's PHP 4.2, Yet 4.3 functions used

Reported by: DD32 Owned by:
Milestone: 2.5 Priority: normal
Severity: normal Version: 2.5
Component: General Keywords: compat has-patch
Focuses: Cc:

Description

Currently WordPress requires PHP 4.2, however, There are few PHP 4.3+ functions in use around WP which do not have a compat function:

ob_get_flush() = wp-includes/widgets.php
html_entity_decode() - wp-admin/import/blogger.php, wp-includes/widgets.php
ob_get_clean() - wp-admin/plugins.php

Any other PHP 4.3+ functions either have logic im place to use alternate methods, or there is a compatible function in compat.php for it.

Attachments (1)

5416.diff (488 bytes) - added by Nazgul 7 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 @ryan7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Requirement bumped to 4.3. [6662]

comment:2 @lloydbudd7 years ago

  • Milestone changed from 2.6 to 2.5

comment:3 @Nazgul7 years ago

  • Keywords has-patch added
  • Resolution fixed deleted
  • Status changed from closed to reopened

The included readme.html also needs to be updated to mention PHP 4.3.

Patch attached.

@Nazgul7 years ago

comment:4 @westi7 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [6667]) Update the required version in the readme too. Fixes #5416 props Nazgul.

Note: See TracTickets for help on using tickets.