WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#54165 closed defect (bug) (duplicate)

Screen options not working

Reported by: jrswgtr Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: administration Cc:

Description

The screen options menu does not seem to work anymore. When I click it, nothing happens.

I checked if it was because of a theme or plugin by disabling all plugins and activating twentytwentyone but that doesn't seem to be the case.

Attachments (5)

8526de44db674c9f4e16a2206d9ed413.gif (1.0 MB) - added by audrasjb 2 months ago.
ezgif-2-a2a905f5b82b.gif (41.0 KB) - added by jrswgtr 2 months ago.
5ddd03b5bd1b19818e4cbab9078f0ced.gif (1.0 MB) - added by audrasjb 2 months ago.
Works fine on Firefox on my side
dashboard-expanded-screen-options.png (79.2 KB) - added by sabernhardt 2 months ago.
Firefox Inspector for #screen-meta container
dashboard-expanded-screen-options-wrap.png (78.8 KB) - added by sabernhardt 2 months ago.
Firefox Inspector for #screen-options-wrap container

Change History (17)

#1 @audrasjb
2 months ago

  • Keywords reporter-feedback added

Hello,
Could you please elaborate on the exact issue (which admin screen? what is the error?) and provide some screenshots if needed?

I tried to reproduce the issue but it works fine on my side (see animated screenshot below).

#2 @jrswgtr
2 months ago

@audrasjb

I uploaded a GIF, i't in the entire admin. I don't get any error messages.

Last edited 2 months ago by jrswgtr (previous) (diff)

#3 @audrasjb
2 months ago

Thanks for the screenshot. Could you please open your browser's console (F12) and copy the eventual errors?

#4 @jrswgtr
2 months ago

@audrasjb

This is all I See:

This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”. wp-admin
Blocked loading mixed active content “http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=5.8”
JQMIGRATE: Migrate is installed, version 3.3.2

#5 @jrswgtr
2 months ago

@audrasjb
It seems to be in Firefox only, at least not in Chrome and Edge (chromium)!

Last edited 2 months ago by jrswgtr (previous) (diff)

@audrasjb
2 months ago

Works fine on Firefox on my side

#6 @audrasjb
2 months ago

Could you please try on a new fresh WordPress install?

#7 @audrasjb
2 months ago

Given the above console message, it looks like you're using some plugins/themes on this installation. So it would be nice to test with a fresh install. Then you may be able to isolate the issue.

@sabernhardt
2 months ago

Firefox Inspector for #screen-meta container

#8 @sabernhardt
2 months ago

Another possibility: the #screen-meta container might be hidden with CSS.

If you use the Inspector, you could see if styles override display: block on that element.

#9 @jrswgtr
2 months ago

I found the issue, It's not a WordPress nor a Firefox bug. The culprit is the Browser extension from Keeper Security https://addons.mozilla.org/en-US/firefox/addon/keeper-password-manager-digita/

Hence all my colleagues were having the same problem!!

So I will have to contact Keeper now to fix the issue.

I'm sorry for your time, but thanks anyway!

Last edited 2 months ago by jrswgtr (previous) (diff)

#10 @jrswgtr
2 months ago

  • Resolution set to invalid
  • Status changed from new to closed

#11 @audrasjb
2 months ago

  • Keywords reporter-feedback removed
  • Version 5.8.1 deleted

Thank you for taking the time to write this feedback!

@sabernhardt
2 months ago

Firefox Inspector for #screen-options-wrap container

#12 @sabernhardt
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution changed from invalid to duplicate

Thanks for mentioning the extension!

I was partially wrong: the screen-options-wrap container still has the hidden class, and the browser extension makes sure those elements are hidden.

If you would like to add any comments, the issue is already tracked on #27697.

Note: See TracTickets for help on using tickets.