WordPress.org

Make WordPress Core

Opened 2 months ago

Last modified 6 weeks ago

#54228 new defect (bug)

In upgrading PHP recommends plugin that can cause issues (stuck plugin)

Reported by: bryanquigley Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: WordPress.org Site Keywords:
Focuses: Cc:

Description

See PHP Compatibility Checker plugin: https://wordpress.org/support/update-php/#before-you-update-your-php-version

See all the warnings here: https://wordpress.org/support/plugin/php-compatibility-checker/reviews/?filter=1 including acknowledged by the developer.

It also can't check PHP 7.4 or 8 which are the two versions we want people upgrading too.

Please don't mention it until it's new version is available, thanks!

I suggest replacing with a basic check can be done by Viewing Details on each installed plugin and trying to see how long ago it was updated, and if PHP is mentioned. You can also check reviews.

Change History (2)

#1 @bryanquigley
2 months ago

At the very least, a warning for people to only use this plugin if they have server access to remove if it gets stuck. (Noted that they just landed something to help with stuckness)

This ticket was mentioned in Slack in #core-test by boniu91. View the logs.


6 weeks ago

Note: See TracTickets for help on using tickets.