Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#54294 closed enhancement (duplicate)

Multisite: The lost password link on a sub-site wp-login.php page points to the main-site

Reported by: henry.wright Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Login and Registration Keywords:
Focuses: multisite Cc:

Description

When a user is on a sub-site wp-login.php page, it would make sense to link to the lost password form on the sub-site instead of linking to the lost password form on the main-site.

Steps to reproduce

  1. Visit the wp-login.php page at subdomain.example.com/wp-login.php
  2. Hover over the "Lost your password?" link below the form
  3. Note the URL points to the main-site

I feel context should be maintained. For example, if a user has visited a sub-site then they shouldn't be taken to the main-site to reset their password if a lost password facility exists on the sub-site.

Change History (2)

#1 @ocean90
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21352.

#2 @henry.wright
3 months ago

Thanks for pointing out the existing ticket @ocean90. This is an issue when the sub-site uses a different language to the main-site.

Note: See TracTickets for help on using tickets.