Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#54297 closed defect (bug) (duplicate)

Multisite: lostpasswordform always posts to the main-site wp-login.php file

Reported by: henry.wright Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Login and Registration Keywords: has-patch
Focuses: multisite Cc:

Description

The lost password form always posts to the main-site wp-login.php file. If the lost password form on a sub-site is being used then I'd expect the form to post to the sub-site wp-login.php file.

Current

<form name="lostpasswordform" id="lostpasswordform" action="<?php echo esc_url( network_site_url( 'wp-login.php?action=lostpassword', 'login_post' ) ); ?>" method="post">

Suggestion

<form name="lostpasswordform" id="lostpasswordform" action="<?php echo esc_url( site_url( 'wp-login.php?action=lostpassword', 'login_post' ) ); ?>" method="post">

Attachments (1)

54297.diff (750 bytes) - added by henry.wright 3 months ago.

Download all attachments as: .zip

Change History (10)

#1 @henry.wright
3 months ago

This is an issue when the sub-site uses a different language to the main-site.

#2 @costdev
3 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Hi @henrywright, this ticket appears to be a duplicate of #21352. Add your thoughts and suggestion to that ticket to help further the discussion on this topic.

#3 @henry.wright
3 months ago

Hi @costdev. Although related, it isn't a duplicate. This ticket refers to the location of the form submission and the #21352 ticket refers to the function that is generating the lost password URL.

Last edited 3 months ago by henry.wright (previous) (diff)

#4 @henry.wright
3 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

#5 @henry.wright
3 months ago

Happy to close this ticket though if you prefer to broaden the scope of the #21352 ticket

#6 @costdev
3 months ago

@henrywright Thanks for clarifying that and correcting me!

Let's see what others think about that. I've updated my comment on that ticket to note that this one is a related ticket, not a duplicate.

@henry.wright
3 months ago

#7 @henry.wright
3 months ago

  • Keywords has-patch added

Attached is 54297.diff. This patch posts to the sub-site wp-login.php file instead of the main-site wp-login.php file.

#8 @ocean90
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #36439.

#9 @henry.wright
3 months ago

Thanks @ocean90

Note: See TracTickets for help on using tickets.