WordPress.org

Make WordPress Core

Opened 5 weeks ago

Closed 5 weeks ago

#54360 closed task (blessed) (duplicate)

Add Menu REST API endpoints from Gutenberg plugin into Core

Reported by: noisysocks Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: REST API Keywords:
Focuses: Cc:

Description (last modified by noisysocks)

  • Add wp/v2/menus endpoint.
  • Add wp/v2/menu-items endpoint.
  • Add wp/v2/menu-locations endpoint.
  • Add any other bits needed by the Navigation block that I've forgotten about 🙂

https://github.com/WordPress/gutenberg/blob/trunk/lib/class-wp-rest-menus-controller.php

Change History (2)

#1 @noisysocks
5 weeks ago

  • Description modified (diff)

#2 @spacedmonkey
5 weeks ago

  • Milestone 5.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #40878.

Note: See TracTickets for help on using tickets.