Make WordPress Core

Opened 2 months ago

Closed 2 months ago

#54456 closed defect (bug) (fixed)

Navigation block view script JS console error

Reported by: mkaz Owned by: audrasjb
Milestone: 5.9 Priority: normal
Severity: normal Version: 5.9
Component: Editor Keywords: has-patch commit
Focuses: Cc:

Description

Error originall reported on Gutenberg repo at: https://github.com/WordPress/gutenberg/issues/36506

The issue is a Windows environment the paths are not being reconciled properly and the core view.min.js file used by the Navigation block is not being loaded in Windows environments.

This can be tested by running Local on Windows and viewing a page using the TwentyTwentyTwo theme

Attachments (1)

54456.diff (2.5 KB) - added by mkaz 2 months ago.

Download all attachments as: .zip

Change History (11)

@mkaz
2 months ago

#1 @sabernhardt
2 months ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 5.9
  • Version set to trunk

Thanks! Using WampServer, that works for me with the view.min.js file.
src='http://localhost/svn/src/wp-includes/blocks/navigation/view.min.js?ver=4942262e50480536aae4cd504a13f19c'

(There's a space missing before the colon, but that could be fixed in the commit.)

This ticket was mentioned in Slack in #core-editor by mkaz. View the logs.


2 months ago

#3 @JeffPaul
2 months ago

  • Keywords needs-testing added

#4 @costdev
2 months ago

  • Keywords needs-testing removed

Test Report


Env

  • WordPress 5.9-alpha-20211117.140912
  • Chrome 95.0.4638.69
  • Windows 10
  • Theme: Twenty Twenty Two
  • Gutenberg Editor
  • Plugin: None activated.


Steps to test

  1. Load any page and check DevTools.

An error is shown:

GET testing-54456.local/wp-content/plugins/C:/Users/<USERNAME>/Local%20Sites/…ncludes/blocks/navigation/view.min.js?ver=4942262… net::ERR_ABORTED 403 (Forbidden)`

  1. Apply the changes in the patch, reload the page and check DevTools.

The error is no longer shown.

Patch is successful.

#5 @hellofromTonya
2 months ago

  • Keywords commit added

Marking for commit.

#6 @davidbaumwald
2 months ago

  • Owner set to davidbaumwald
  • Status changed from new to reviewing

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


2 months ago

#8 @audrasjb
2 months ago

  • Owner changed from davidbaumwald to audrasjb

Self assigning for commit.

#10 @audrasjb
2 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 52291:

Editor: Avoid a JS console error on the Navigation block view.

Props mkaz, sabernhardt, costdev.
Fixes #54456.

Note: See TracTickets for help on using tickets.