Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#54485 closed task (blessed) (duplicate)

Build tools: Upgrade webpack to v5

Reported by: noisysocks's profile noisysocks Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: early
Focuses: Cc:

Description

While updating packages for WP 5.9 I noticed build errors due to new JavaScript syntax such as ??= appearing in @wordpress/components. We worked around this by removing the new syntax but I suspect the true cause of the problem is that Core needs to upgrade from v4 of webpack to v5. We should look into doing this for the next major release.

https://webpack.js.org/migrate/5/

Change History (1)

#1 @desrosj
2 years ago

  • Milestone 6.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #51750.

Note: See TracTickets for help on using tickets.