WordPress.org

Make WordPress Core

Opened 8 weeks ago

Closed 8 weeks ago

#54491 closed defect (bug) (fixed)

Site Editor: Move the link color styles to the footer

Reported by: noisysocks Owned by: noisysocks
Milestone: 5.9 Priority: normal
Severity: normal Version:
Component: Editor Keywords: has-patch
Focuses: Cc:

Description

The fix in https://github.com/WordPress/gutenberg/pull/35425 has seemingly not properly been backported into Core. Let's make sure that the changes in that PR are in Core.

Step-by-step reproduction instructions:

  1. Try using 2022 theme
  2. Notice the header doesn't have an extra margin at the top on Gutenberg but does so with just WP trunk.

First reported in https://github.com/WordPress/gutenberg/issues/36743.

Change History (5)

#1 @noisysocks
8 weeks ago

Hi @youknowriad. The changes in https://github.com/WordPress/gutenberg/pull/35425 already exist in Core:

https://github.com/WordPress/wordpress-develop/blob/trunk/src/wp-includes/block-supports/elements.php#L71-L81

I'm not able to see any extra padding at the top of the Header when using Twenty Twenty-two, but admittedly I'm not 100% sure what I'm looking for. Could you please double check?

#2 @youknowriad
8 weeks ago

I still see the issue with the padding in the frontend of 2022, that said, while the symptoms are similar, I think the issue is another missed backport: the skip link position and not the link color ones. I'll work on that asap.

This ticket was mentioned in PR #1939 on WordPress/wordpress-develop by youknowriad.


8 weeks ago

  • Keywords has-patch added; needs-patch removed

Trac ticket: https://core.trac.wordpress.org/ticket/54491

This PR backports the following Gutenberg PR into Core https://github.com/WordPress/gutenberg/pull/34986

#5 @noisysocks
8 weeks ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 52243:

Themes: Move the skip link to outside the canvas in block themes

Fix Twenty Twenty-one having an erroneous margin above the Header template part
by moving the skip link outside of the wp-site-blocks canvas.

This is a backport of https://github.com/WordPress/gutenberg/pull/34986.

Props youknowriad.
Fixes #54491.

Note: See TracTickets for help on using tickets.