WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 5 weeks ago

#54570 closed defect (bug) (invalid)

Improve accessibility for WordPress with NVDA

Reported by: hnm1969 Owned by:
Milestone: Priority: normal
Severity: major Version: trunk
Component: Themes Keywords: needs-patch
Focuses: accessibility, template, multisite, performance Cc:

Description

Hi, I'm a blind person using WordPress, I'm having a hard time managing my website. Currently, I am using Windows 10 version 20h2 with NVDA screen reader and Chrome browser. You know, building a website or managing, operating, and arranging layouts for the blind is very difficult. So I can't reach and master it. For example, the Gutenberg editor is a very difficult thing to be compatible with NVDA because it is drag-and-drop or has some themes that are not accessible and it does not meet the wcag standard. So I hope you improve soon. Also, on flatsome there is a page builder and it requires me to use the mouse to drag and drop but since I'm a screen reader I can't do it. It is very difficult for a disability to manage or build and design a website with WordPress on their own with paid themes. Sometimes the page builder tools will be difficult to reach for the visually impaired. It itself has to do with drag and drop. That is very difficult. We cannot fully access WordPress using screen readers. You know, I love customization,
I always like to personalize my website so I personally don't like the
available themes, it simply doesn't meet WCAG standards so I usually
spend a little time. It takes time to redesign as well as edit or code
another theme to make it more accessible or fully accessible to
everyone and it is necessary as currently, WordPress does not have
these attributes. required for screen readers. For example, in html
with this accesskey attribute, when you attach it, your website will
support specific shortcuts, press alt+h to return to the home page or
in the code I will add accesskey=h, However, a theme in WordPress
doesn't have those. I think, an interface that makes the most of HTml
and limits css and java scripts to optimize the experience for users
with disabilities is great. For my sighted friends, doing that will
make the website load faster. At the same time, helping to better
reach all users. Except, there are things that require the use of java
script or css like aesthetic enhancement or some accessibility related
thing that css or java script can do. That depends on whether the
theme is good or not? I am visually impaired myself so accessibility
will be my priority so there is no reason for me to develop a new
theme. The difficulty here for me is that even though I already have a
pre-coded html file, I don't know how to convert the html template
file into a WordPress theme. I have followed what is on the internet
and good tutorials but doing it manually will take a lot of time,
because I still have many customers waiting for my order. I don't want
to miss that opportunity. I would like a tool to help me with this. In
addition, increasing contrast, changing colors, and composition is
difficult for visually impaired people like me. I think it will take
long enough to find a solution to this problem. I believe that
WordPress will have an improvement that is more interested in visually
impaired developers. I myself split the html file to embed it in php
but it crashed so I had to re-code it from scratch. I think, WordPress is a
platform that blind people can use it to optimize web development
time. Most of the new tools integrated on WordPress are drag and drop, so the screen reader is difficult to interact with. I hope, WordPress will continue to improve to be more visually impaired. To help them take the initiative in website development. Thanks, I look forward to your feedback and improvement. Currently, I am using the latest version of WordPress. I hope, my request will be resolved.

Attachments (2)

index.html (7.0 KB) - added by hnm1969 7 weeks ago.
I have integrated a raw theme file and I want to convert it into a WordPress theme.
index.2.html (19.9 KB) - added by hnm1969 7 weeks ago.
I have integrated a raw theme file and I want to convert it into a WordPress theme.

Download all attachments as: .zip

Change History (4)

@hnm1969
7 weeks ago

I have integrated a raw theme file and I want to convert it into a WordPress theme.

@hnm1969
7 weeks ago

I have integrated a raw theme file and I want to convert it into a WordPress theme.

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


6 weeks ago

#2 @ryokuhi
5 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hello @hnm1969, welcome on WordPress Trac and thank you for opening this ticket.

I can understand the difficulties you have to face while managing your website, and I can feel your frustration at not being able to use WordPress to its full potential because it isn't completely accessible.

In the ticket's description, you mention a lot of different issues, which I'm going to address in a few moments. Unfortunately, we don't really have any specific solution to your issues: the biggest problem is that you aren't describing any specific problem that we can isolate, reproduce and fix, and, as such, we can't really do anything to solve the problems you are facing. Which is why I'm closing this ticket as invalid: it is not that we don't believe that you are facing issues with WordPress, but simply that this specific ticket doesn't allow us to identify a problem that can be fixed.

Still, as you choose to spend time to open this ticket, I'm sure that you're willing to contribute to the WordPress project and, as such, I'll try to give you a few suggestions.

Reporting issues

As mentioned above, the biggest problem with this ticket is that you are referring to a lot of different issues. The best way to get a ticket solved is to open a new ticket for each different issue you are facing. Also, adding as much detailed instructions as possible on how to reproduce the issue will make it easier for people to reproduce the bug and fix it: ideally, a list of steps to follow is the best solution.

Another important thing to do is identify where to report a problem you are facing.

  • If you find an issue with the WordPress software itself (that is, what you get when you do a fresh install), it should be reported here on Trac by opening a new ticket and, in case, adding the accessibility focus (just like you did with this ticket).
  • If you find an issue with one of WordPress bundled themes (that is, one of the themes which name start by Twenty, such as the Twenty Twenty-One theme), you have to report it here and add the Bundled Theme component.
  • If you find a problem with another theme or with a plugin, you have to reach out to the theme or plugin developer. If the theme or plugin is included in the wordpress.org repository, you can head to the theme or plugin's page and find the "View support forum" link to visit the theme or plugin's individual forum. Unfortunately, in most cases, the theme or plugin developer won't have to fix the issue: plugins don't undergo any accessibility check; the situation is a bit better with themes, more about that below.
  • If you find an issue with the Gutenberg editor, development happens on GitHub (here's the direct link to the repository), so you should open an issue there.

Assistive technologies

As a blind person, you have to rely on a screen reader and keyboard navigation. You mention that it's difficult for you to use Gutenberg, as it's a visual editor and a lot of its features work through drag-and-drop. While that is true, it's also true that we strive to make the block editor usable even for people who can't use a mouse, so you should still be able to do everything by using only a keyboard and a screen reader. It can be harder, it may require more time, the interface probably won't be clear, but, at the end of the day, you should still be able to use the Gutenberg editor only with a keyboard and a screen reader. If you know about a feature that is available, but that you can't use because it doesn't work using only the keyboard, please let us know by opening an issue in the Gutenberg repository, so that we can fix it.

Themes

As mentioned above, we have "control" only on themes that are uploaded on the wordpress.org repository: these themes are free and released under the GPL license. Regarding commercial themes, which you can buy on other website, we have no control over them: you should probably check live demos, get in touch with the seller and discuss the theme's accessibility features before you buy them.

All themes uploaded on the wordpress.org repository undergo some basic accessibility checks: you can have a look at them on the page about theme requirements. Moreover, there are some themes which have the accessibility-ready tag: these themes are subject to stricter checks (you can check the requirements on the related page in the Theme Review Handbook) and, as such, are probably the best choice if you need a solid accessibility base to build on. As a side note, note that no theme can be declared compliant with WCAG, because these guidelines relate to content and themes don't have any content of their own.

As far as I have understood, you aren't only a content creator, but also a developer, and, as such, you're looking for information on how to create a WordPress theme from an HTML template. In this case, I suggest that you have a look at the code of accessibility-ready themes published in the repository. Also, there is a Theme Handbook, specially dedicated to theme developers, which contains all the basic information on how to create a theme. I don't know about the accessibility of these documents, but in case you find some parts which aren't accessible, let us know so that we can fix it.

Contributing to WordPress

Finally, I'd like to add a few extra lines to invite you to take an active role inside the WordPress community. You would be an invaluable resource to the improvement of WordPress itself.

If you feel like giving it a try, you can have a look at what the Accessibility Team does by visiting our website. The best way to get in touch is using Slack: here are instructions on how to join, once you've successfully joined you can find the Accessibility team in the #accessibility channel.

Unfortunately, we can't give you direct support, but working on WordPress core will help you understand how WordPress works under the hood and this will help you improve as a WordPress developer. We really hope to see you there!

Note: See TracTickets for help on using tickets.