WordPress.org

Make WordPress Core

Opened 6 weeks ago

Closed 6 weeks ago

#54590 closed defect (bug) (reported-upstream)

Bug in footer of full site editing WP 5.9 Beta 1

Reported by: ejca Owned by:
Milestone: Priority: normal
Severity: normal Version: trunk
Component: Editor Keywords:
Focuses: Cc:

Description

Hello. I have installed WordPress 5.9 Beta 1.

When I edit the footer, I have added a button and, when I try to remove it, the system returns an error. I attached video:
https://drive.google.com/file/d/1CnneSjz6pt9d1yfeahbBw0VRjUgILVvy/view?usp=sharing

Change History (5)

#1 @hellofromTonya
6 weeks ago

  • Component changed from Build/Test Tools to Editor
  • Keywords reporter-feedback added
  • Milestone changed from Awaiting Review to 5.9
  • Version set to trunk

Hello @ejca,

Welcome to WordPress Core's Trac! Thank you for opening a ticket to report this issue.

The Google Doc you shared is access protected. Could you please open it for all to view?

It's helpful to type out the error you're experiencing for those who may not have access or aren't able to view (see) the video.

Also, please share step-by-step instructions on how to reproduce including what theme and plugins are activated. Why? These instructions help contributors investigate the reported issue.

Moving into 5.9 for visibility. Changing the component to Editor, pending more information.

#2 @ejca
6 weeks ago

Hy, Tonya.
I've just opened video access, sorry :)
I used a clean installation: only WordPress 5.9 Beta 1 with Twenty Twenty Two theme. Later, I've added Gutemberg, but nothing changed.
The problem is in footer block. I added a button. But, when I want to delete it with "Remove button" in submemu, the system says: "The editor has encountered an unexpected error", and two buttons: "Attempt recovery" and "Copy the error". "Copy the error" doesn't seem to do nothing. When I click "Attempt recovery", I go back to the starting point.
Ty.

Last edited 6 weeks ago by ejca (previous) (diff)

#3 @hellofromTonya
6 weeks ago

  • Keywords reporter-feedback removed

Hmm, that's interesting. This issue needs to be investigated and fixed upstream in Gutenberg and then its fix backported to Core.

@ejca Are you able to open an issue in Gutenberg? To do so, please go here to the Issues interface, select "Bug report" by clicking on the "Get started" button, and then fill out the issue form with what you've shared here in Trac.

If yes, please share the link to the Gutenberg issue you open, as this will help for tracking 5.9 issues.

#4 @ejca
6 weeks ago

Ok.
This is the link:
https://github.com/WordPress/gutenberg/issues/37158

Thank you, Tonya.

#5 @hellofromTonya
6 weeks ago

  • Milestone 5.9 deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Reported upstream. Closing this ticket as the fix (when ready in Gutenberg) will be backported to Core as part of any package update.

Note: See TracTickets for help on using tickets.