Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#54749 closed defect (bug) (fixed)

Re-enable E2E testing for the 5.8 branch

Reported by: desrosj's profile desrosj Owned by: davidbaumwald's profile davidbaumwald
Milestone: 5.9 Priority: normal
Severity: normal Version: 5.9
Component: Build/Test Tools Keywords: has-patch fixed-major dev-reviewed commit
Focuses: Cc:

Description

[52449] adjusted the workflow for testing old branches after creating the 5.9 branch.

For E2E tests, only the most recent supported branch is tested regularly. But as of 5.8, there are more tests than just “Hello World” ones (see #52905), so the same pattern as PHP Compatibility testing should be used for E2E tests going forward.

Attachments (1)

54749.diff (1.2 KB) - added by desrosj 2 years ago.

Download all attachments as: .zip

Change History (9)

@desrosj
2 years ago

This ticket was mentioned in Slack in #core by desrosj. View the logs.


2 years ago

#2 @hellofromTonya
2 years ago

There are a total of 3 e2e tests on the 5.8 branch:

  • 2 for Quick Draft
  • 1 for "Hello World"

Though the coverage is tiny, if a regression does happen in those coverage areas, then there's an advantage for running them as they might reveal it. Performance-wise, running these 3 tests should be quick.

Overall, I think it is worth wiring up these tests to run. Thumbs up from me!

#3 @davidbaumwald
2 years ago

  • Owner set to davidbaumwald
  • Resolution set to fixed
  • Status changed from new to closed

In 52546:

Build/Test Tools: Re-enable E2E tests for the 5.8 branch.

After the 5.9 branch was created, [52449] updated the workflow for testing old branches to include 5.9. However, the E2E tests -branch condition was updated to 5.9 instead of adding an additional branch condition for 5.9. This commit re-enables the E2E tests for 5.8.

Props desrosj, hellofromTonya.
Fixes #54749.

#4 @davidbaumwald
2 years ago

  • Keywords fixed-major dev-feedback added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for backport to the 5.9 branch.

#5 @hellofromTonya
2 years ago

  • Keywords dev-reviewed added; dev-feedback removed

👍 for backport

#6 @hellofromTonya
2 years ago

  • Keywords commit added

@davidbaumwald @desrosj is this on your radar for backport to 5.9?

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


2 years ago

#8 @desrosj
2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In GitHub Actions, scheduled events only run in the repositories primary branch. Since this change was made in trunk already, we can just close this out as fixed and leave as 5.9 to reflect when the change was made.

I go back and forth for when to include changes to these files in backports (keeping the files up to date is easier when backporting other changes), but I think it makes more sense to leave these files as they are when branching occurs, or to remove them entirely.

We can close this one out, and when the next round of GHA related backports occurs, I can make a final decision here.

Note: See TracTickets for help on using tickets.