Make WordPress Core

Opened 2 years ago

Closed 7 days ago

#54842 closed enhancement (reported-upstream)

inconsistent handling of align settings on Pages / Templates

Reported by: tinomueller's profile tinomueller Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: ui, administration, template Cc:

Description

Maybe i'm not getting the full concept behind but it feels a bit clumsy to setup the alignment/wide settings for the blocks on pages/posts or templates/template-parts.

Example:

  • setup a header template using Gutenberg on a normal page
  • - create Cover block with background color
  • - insert a simple text
  • - set alignment to full-width
  • - copy the cover and insert it into a template-part

Now, if i want to edit the template part the alignment/sizing option is not available anymore. (see screenshots)

Attachments (2)

template-editor-screen.PNG (18.7 KB) - added by tinomueller 2 years ago.
template editor
page-editor-screen.png (22.6 KB) - added by tinomueller 2 years ago.
page editor

Download all attachments as: .zip

Change History (6)

@tinomueller
2 years ago

template editor

@tinomueller
2 years ago

page editor

#1 @tinomueller
2 years ago

  • Summary changed from inconsitent handling of align settings on Pages / Templates to inconsistent handling of align settings on Pages / Templates

#2 @tinomueller
2 years ago

  • Component changed from General to Themes

#3 @tinomueller
2 years ago

  • Type changed from defect (bug) to enhancement

#4 @poena
7 days ago

  • Component changed from Themes to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Hi @tinomueller.
You are not alone in expressing this, it is a frequently asked question about working with blocks in the different editors.

Blocks have alignment options depending on their parent. In the Site Editor, the blocks need to be placed inside a container like a group block with specific settings enabled.
In the Post editor, this is not needed, because the blocks are, in a sense, already inside a post content block.

This is a known issue, the contributors who are working on the editor have not found the best way to solve it yet.

I am closing this ticket as a duplicate of an issue reported in the Gutenberg GitHub repository, because there are more discussions and a better explanation there:
https://github.com/WordPress/gutenberg/issues/55799

Note: See TracTickets for help on using tickets.