Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#54847 closed defect (bug) (reported-upstream)

Block locks up, cannot edit header/paragraph text

Reported by: tylertork's profile TylerTork Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.8.3
Component: Editor Keywords:
Focuses: Cc:

Description

If using a Columns block with text within the column -- a Paragraph or Heading block -- I can cause the text block to "lock up" and not allow further editing of the text by clicking to place the text cursor within the block, then clicking elsewhere in the same block while holding down Shift.

The block gains a blue outline and the text cursor disappears. All other Heading and Paragraph blocks start behaving in the same way. There are no error messages in the browser console.

The only way I've found to unlock the block to allow further editing, is to delete it then restore it with Ctrl+Z.

Using WP 5.8.3 and latest Firefox browser, Neve theme (but I've seen this with other themes also, including Graphene). All plugins deactivated. Cleared all caches. Problem has also been confirmed to occur in Chrome.

Change History (2)

#1 @hellofromTonya
2 years ago

Hello @TylerTork,

Welcome to WordPress Core's Trac 👋 Thank you for reporting this issue.

The blocks are maintained upstream in the Gutenberg project, where contributors investigate, discuss, and resolve issues. Then once resolved, each fix is backported to WordPress Core for inclusion into a release.

The process starts in Gutenberg by searching for the issue here and, if not reported, then by opening a bug report using the `Issue: Bug report` interface here.

Some tips when reporting:

  • Include step-by-step instructions on how to reproduce the issue
  • Provide screenshots or a screenshare gif or video (seeing the issue is helpful)

Once reported, please copy the issue's URL and paste as new comment on this ticket. Why? To wire/link Core and Gutenberg tracking together.

#2 @hellofromTonya
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.