WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#5485 closed enhancement (duplicate)

Export with gzip support

Reported by: mastermind Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description (last modified by lloydbudd)

In ticket #3688, it was suggested to reopen a ticket for requestion gzip support for the import/export functionality

Update: #5522 supports gzip compressed files on the import side.

XML is very bloated, and many hosts have low upload limits. Therefore it would be a very nice to be able to import/export gzip compressed files.

Alternatively, it would be nice to be able to import files that already are on the server, i.e. uploaded via FTP (but that's probably something for another ticket).

Change History (3)

comment:1 tellyworth6 years ago

#5522 supports gzip compressed files on the import side. I'd suggest we don't support it at export just yet, since most installs can't import compressed files.

comment:2 lloydbudd6 years ago

  • Description modified (diff)
  • Summary changed from Import/Export with gzip support to Export with gzip support

tellyworth, I don't see a reason to hesitate getting gzip compression into trunk.

(I agree it wouldn't be appropriate for this to be deployed to WordPress.com for example until after a release with importing of gzip.)

comment:3 lloydbudd6 years ago

  • Milestone 2.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3632

Note: See TracTickets for help on using tickets.