Make WordPress Core

Opened 2 years ago

Closed 17 months ago

#54863 closed defect (bug) (invalid)

Loop in WP core

Reported by: wushuban's profile wushuban Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: General Keywords: close reporter-feedback
Focuses: performance Cc:

Description

Hi,

We recently had a performance issue with one of our websites.
It works with a custom made theme.
The frontend and backend were very slow, and sometimes led to 503 errors.

We contacted our server supplier (cyon.ch) which told us:

"There are some very heavy load scripts, specially if you upload pictures. That causes the following loop:
SELECT option_value FROM wp_options WHERE option_name = 'can_compress_scripts' LIMIT 1
SELECT option_value FROM wp_options WHERE option_name = 'can_compress_scripts' LIMIT 1
SELECT option_value FROM wp_options WHERE option_name = 'wp_installer_settings' LIMIT 1
SELECT option_value FROM wp_options WHERE option_name = 'can_compress_scripts'"

which seems to be a WP core query.
It is better after deactivating some plugins, but the problems is remaining.

Thank you for checking.

Change History (3)

#1 @desrosj
2 years ago

  • Keywords close added

Hi @wushuban,

Welcome to Trac!

I'm having trouble understanding where the issue is stemming from because there is not enough information provided. If you are still able to reproduce the problem, please reply with a list of steps that someone can take on a fresh install with no plugins active and a default theme (a Twenty x theme) to reproduce the problem reliably.

If the condition cannot be reproduced with no active plugins, it's not a core issue and the WordPress.org Support Forums is a better place to seek help for this problem.

#2 @desrosj
2 years ago

  • Keywords reporter-feedback added

#3 @hellofromTonya
17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hello @wushuban,

I too am having difficulties determining if this could be a Core issue. As @desrosj noted, more information is needed including step-by-step instructions of how contributors can reproduce the issue you saw 12 months ago.

With no additional information, the WordPress.org Support Forums are likely the better place to seek help for this problem.

I'll close this ticket.

However, if the problem persists and after following the steps provided, please feel free to reopen this ticket and provide the step-by-step instructions to reproduce and any additional information that can help contributors investigate. Thank you.

Note: See TracTickets for help on using tickets.