Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#54890 closed defect (bug) (duplicate)

If a taxonomy is created that has commas in the name, it creates multiple separated terms when adding to a post

Reported by: barrychapman's profile barrychapman Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9
Component: Taxonomy Keywords: needs-patch
Focuses: Cc:

Description

I have a post, where I have added a custom taxonomy.

I defined the taxonomy in the editor:

Name: Lipid Panel - LDL, HDL, Trig, TC, Ratio
Slug: lipid-panel
Description: etc...

This is all fine, now when I select the term from the side bar on the post editor, it creates the following terms:

  • LDL
  • HDL
  • Trig
  • TC
  • Ratio

WordPress should be able to link this not by the term name, right?

Change History (4)

#1 @azouamauriac
2 years ago

  • Keywords reporter-feedback added

Hello @barrychapman thank for your report, but i'm not able to reproduce the issue. Could you please provide more details(video, screenshot...)? thank you

Here is what i get on trunk branch after follow the steps you sent
https://prnt.sc/26iinaa https://prnt.sc/26iij19

Last edited 2 years ago by azouamauriac (previous) (diff)

#2 follow-up: @SergeyBiryukov
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #14691.

#3 in reply to: ↑ 2 @barrychapman
2 years ago

Replying to SergeyBiryukov:

Hi there, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #14691.

You really should specify that commas cannot be used, instead of allowing them and butchering the terms.

That other issue was opened ELEVEN YEARS AGO.

#4 @azouamauriac
2 years ago

  • Keywords needs-patch added; reporter-feedback removed

I'm able to reproduce the issue, but i have installed classic editor before...

Note: See TracTickets for help on using tickets.