WordPress.org

Make WordPress Core

Opened 13 years ago

Closed 13 years ago

#5494 closed defect (bug) (fixed)

Improperly formed tag field inputs can create blank tags

Reported by: ionfish Owned by:
Milestone: 2.5 Priority: normal
Severity: normal Version: 2.5
Component: General Keywords: has-patch commit
Focuses: Cc:

Description

Similar to #5412, if you put in a string with a bunch of commas into the tag field you can create blank tags. This is the string I used:

testtest2,test3

Which generated several blank tags in addition to 'test', 'test2' and 'test3'.

Attachments (1)

validate_terms.patch (429 bytes) - added by ionfish 13 years ago.
Drop blank terms before saving, per jhodgdon on IRC.

Download all attachments as: .zip

Change History (6)

#1 @ionfish
13 years ago

Looks like Trac ate my commas.

test,,test2,,,test3

@ionfish
13 years ago

Drop blank terms before saving, per jhodgdon on IRC.

#2 @JeremyVisser
13 years ago

  • Keywords has-patch added; needs-patch removed

#3 @JeremyVisser
13 years ago

  • Keywords commit added

Patch confirmed to fix bug.

#4 @JeremyVisser
13 years ago

  • Milestone changed from 2.5 to 2.4

#5 @ryan
13 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6424]) Don't create blank terms. Props ionfish and jhodgdon. fixes #5494

Note: See TracTickets for help on using tickets.