Make WordPress Core

Opened 2 years ago

Closed 20 months ago

#54963 closed defect (bug) (reported-upstream)

5.8.3 official version i hebrew - got updated to 5.9.1 alpha in english !!!

Reported by: looknear's profile looknear Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.9
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

Whats wrong here?
why a stable version got update into development version??
and from HE installation - into US one?...

someone really made a mess this time...
Thank you for NOT doing QA for the upgrade process...

Change History (7)

This ticket was mentioned in Slack in #polyglots by vladytimy. View the logs.


2 years ago

#2 @dd32
2 years ago

Hi @looknear,

There appears there was a packaging mistake made when the Hebrew package was released - You're currently running the 5.9 code and should've received the Hebrew translation files, but it's incorrectly got the 5.9.1-alpha version number displayed.
I've manually re-released the Hebrew 5.9 package to contain the proper version number, all other contents of the file were correct (It doesn't have 'development' code, only intended release code).

You should be able to 'downgrade' by visiting Dashboard -> Updates and installing 5.9 directly.
You'll also likely find a Translations update will happen at the same time as telling to install 5.9.

If you don't do this, there'll be no problems, as once WordPress 5.9.1 comes out, your site will correctly update to it still.

#3 @SergeyBiryukov
2 years ago

  • Component changed from Canonical to Upgrade/Install

#4 @looknear
2 years ago

It's not only the version code.
the language pack of Hebrew is missing.
i added missing line to wp-includes/version.php
but still - the site base changed to US-en, so button now say:
"install en-US-5.9"...
and "update manually to the night version..."
and it's clearly write "you are using the development version..."
what you suggest?

Last edited 2 years ago by looknear (previous) (diff)

This ticket was mentioned in Slack in #core-test by hellofromtonya. View the logs.


2 years ago

This ticket was mentioned in Slack in #core-upgrade-install by costdev. View the logs.


20 months ago

#7 @costdev
20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

As the original issue of this ticket was due to a package mistake that has now been resolved, let's close this ticket as reported-upstream.

@looknear In terms of resolving the issue with your website's current version of WordPress, if you are still encountering issues, please head on over to the support forums to get some help with fixing this.

Note: See TracTickets for help on using tickets.