Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#54969 closed defect (bug) (worksforme)

PHP Fatal error when upgrading WordPress to 5.9

Reported by: garak734's profile garak734 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9
Component: Upgrade/Install Keywords: reporter-feedback
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Clicked on manual upgrade link on dashboard to upgrade from 5.8.2 to Version 5.9-en_GB.

Message on screen: There has been a critical error on this website.

Error message in debug.log:

PHP Fatal error:  Uncaught Error: Call to a member function switch_to_blog() on null in C:\wamp64\www\xxxxxx\wordpress\wp-includes\cache.php:239
Stack trace:
#0 C:\wamp64\www\xxxxxx\wordpress\wp-includes\load.php(727): wp_cache_switch_to_blog(1)
#1 C:\wamp64\www\xxxxxx\wordpress\wp-settings.php(131): wp_start_object_cache()
#2 C:\wamp64\www\xxxxxx\wordpress\wp-config.php(116): require_once('C:\\wamp64\\www\\x...')
#3 C:\wamp64\www\xxxxxx\wordpress\wp-load.php(50): require_once('C:\\wamp64\\www\\x...')
#4 C:\wamp64\www\xxxxxx\wordpress\wp-admin\upgrade.php(18): require('C:\\wamp64\\www\\x...')
#5 {main} thrown in C:\wamp64\www\xxxxxx\wordpress\wp-includes\cache.php on line 239

Change History (4)

This ticket was mentioned in Slack in #core-test by hellofromtonya. View the logs.


2 years ago

#2 @hellofromTonya
2 years ago

  • Keywords close reporter-feedback added
  • Severity changed from blocker to normal

Hello @garak734,

Welcome to WordPress Core's Trac!

Sorry you had issues upgrading. This is likely caused by a failed installation. Looking at your support forum history, appears your site is now running on 5.9.

Did doing attempting to reinstall solve the problem?

As it seems your site is now running on 5.9, I'll mark this ticket for close consideration but give you time to reply back just in case.

#3 @SergeyBiryukov
2 years ago

  • Description modified (diff)

Looking at the error log, it seems like the $wp_object_cache global was not properly initialized for some reason.

Are you using an external object caching plugin?

#4 @desrosj
2 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Because there are no answers to follow up questions, there's nothing that can be done here.

Going to close out, but please reopen if you are still experiencing the issue @garak734. If you've solved it, please share the root of your problem for others to benefit from should they read this ticket in the future.

Note: See TracTickets for help on using tickets.