Make WordPress Core

Opened 20 years ago

Closed 19 years ago

#550 closed defect (bug) (worksforme)

Error with comment status in functions-comments.php with comment status

Reported by: anonymousbugger's profile anonymousbugger Owned by: matt's profile matt
Milestone: Priority: normal
Severity: minor Version: 1.2
Component: General Keywords:
Focuses: Cc:

Description

When posting an article without touching any of the default settings (having set default_comments_status and default_ping_status to zero using the checkboxes in the 'Discussion' tab), I'd often get a "Comments (0)" instead of a "Comments Off". This only happened when posting with the default options (simple, nothing touched). It seems what caused this was that the comment_status and ping_status values in the SQL database (wp_posts) were blank (set to the default '0') . In functions_comments.php, it only places a "comments off" value if comment_status and ping_status are set to "closed". To resolve this issue, I went to the options page (class=ALL) and set default_comment_status and default_ping_status to "closed". Again, the issue is in functions-comments.php as it only checks to see if the comment and ping status reads "closed" instead of both closed or zero.

Change History (4)

#1 @anonymousbugger
20 years ago

  • Patch set to No

#2 @matt
19 years ago

  • fixed_in_version set to 1.5
  • Owner changed from anonymous to matt
  • Resolution changed from 10 to 20
  • Status changed from new to closed

#3 @2fargon
19 years ago

  • Status changed from closed to assigned

This exists with version 1.5.

#4 @westi
19 years ago

  • Resolution changed from fixed to worksforme
  • Status changed from assigned to closed

Tested in Current 1.6-alpha trunk rev 2980 and works fine for me both with and without the nice visual editing enabled.

Note: See TracTickets for help on using tickets.