Make WordPress Core

Opened 16 years ago

Closed 16 years ago

Last modified 17 months ago

#5501 closed defect (bug) (invalid)

next_posts_link broken on custom page with template of the same name

Reported by: drphil9001's profile drphil9001 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Template Keywords:
Focuses: Cc:

Description

If you have a Page and a template that is named the same name as the Page, the next_posts_link and previous_posts_link do not work. Note that this is not the file name, but rather the Template name in the file itself.

The following steps will reproduce this bug:

  1. Copy index.php to Blog.php in the default theme
  2. Give Blog.php the Template Name "Blog"
  3. Write > Write Page
  4. Enter "Blog" for the page name with no content
  5. Select "Blog" as the page template.
  6. View the page.

Change History (1)

#1 @xknown
16 years ago

  • Milestone 2.5 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket as invalid because next_posts_link and previous_posts_link are not supposed to work on individual pages or posts.

Please reopen if I have misunderstood your intentions.

Note: See TracTickets for help on using tickets.