Make WordPress Core

Opened 2 years ago

Last modified 4 months ago

#55019 new defect (bug)

Missing the Upload Featured image and Categories option after update the WP 5.9

Reported by: kuuuzya's profile Kuuuzya Owned by:
Milestone: Awaiting Review Priority: normal
Severity: major Version: 5.9
Component: Post Thumbnails Keywords: needs-patch needs-testing has-screenshots
Focuses: Cc:

Description

Hello. With the update to WordPress 5.9, I discovered one significant inconvenience. I read all the descriptions, searched the forum, but did not find how to solve a problem. The only way, which is working now – to log out, delete all cookies for the website in the browser, log in back and edit ONE post. For the second post, the problem is back and I need to log out and delete cookies again.

And yes, the problem occur even when I deactivate all plugins and use the default theme.

https://i.ibb.co/0KSmCXK/2022-02-01-08-56-27.png

The point is that my theme (like many others) is designed to be used with Featured Image. Previously, it was in the right column in the admin panel, where I can select a picture and the theme displayed as the cover of the post. Also, there was a list with categories, but now it's empty.

https://i.ibb.co/Br330Hp/2022-02-01-08-57-14.png

And of course, I have a lot of categories. And no, I can't activate the Featured image in settings, cause there is NO such setting in the preferences. Sorry for the Russian language on the screens, but you can see that these elements just don't exist.

https://i.ibb.co/9nFgYcH/2022-02-01-08-56-54.png

Now I need to add a block in the text itself with the Featured Image. But the problem is that the theme takes a picture from this block and puts it on the cover. Plus, because I inserted the image into the text, it appears in the text as well. I end up with a duplicate image on the page.

I think this is very strange. Please, fix it, cause I can't work with the 5.9 :( We need to spend doubled time on 1 post. Thank you in advance.

Attachments (1)

Снимок экрана 2022-02-01 в 08.57.14.png (256.0 KB) - added by Kuuuzya 2 years ago.

Download all attachments as: .zip

Change History (9)

#1 @stevenjaycohen
2 years ago

Hey @Kuuuzya can you jump over to your Installed Themes and see if everything that was installed BEFORE the v5.9 upgrade is still there now?

I had exactly the same issue as you describe. My site is powered by a child of the Twenty Twenty theme. When I checked installed themes, I could see 2021. 2022. and my child theme but no 2020.

Wordpress reported my LIVE child theme as broken (of course it was, it needed 2020 to function).

Wordpress also THOUGHT that 2020 was installed when I went to try and reinstall it from the New Theme Selector.

So, to fix it, I needed to install 2020 old school (FTPing it to the right folder).

Once the 2020 theme was in place, the issues resolved themselves.

So, the issues you and I found seem to be caused by:
1. v5.9 DELETING A THEME in some cases
2, The WordPress site REFUSING TO ALLOW THE REINSTALL OF A THEME because it thinks the theme is still installed

The WORKAROUND is:
Reinstall the missing theme MANUALLY (FTP/etc)

Last edited 2 years ago by stevenjaycohen (previous) (diff)

#2 follow-up: @Kuuuzya
2 years ago

@stevenjaycohen yes, I've checked this point already. Everything is ok :( I have one theme and one child theme for it. So, two themes are in their places.

#3 in reply to: ↑ 2 @stevenjaycohen
2 years ago

Replying to Kuuuzya:

@stevenjaycohen yes, I've checked this point already. Everything is ok :( I have one theme and one child theme for it. So, two themes are in their places.

Are you checking via the GUI or using an external program (terminal or FTP program for example)?

Like I said, v5.9 was confused about whether everything was installed properly anymore.

Can you try re-uploading both your parent and child themes to the themes folder via FTP or some other external method?

#4 @jhmonroe
14 months ago

Hey! I had this exact same problem and solved it finally**
I was also missing Featured Image/Categories/Tags (in WP 6.1.1) no matter which theme I used.

Troubleshooting Steps:
1) Tried all the obvious solutions forums suggest: screen options/sidebar prefs for gutenberg editor, deactivated plugins, use a WP 20XX theme, reinstalled WP core, tried Site Health/Troubleshooting mode etc. None solved.

2) Was going to try all those tests on my localsite installation and the missing sidebar items already showed up. So I knew it had to do with my remote site only.

3) One article mentioned regenerating permalinks. This did not solve, but it reminded me when I've had very mysterious problems in the past that nothing else seems to solve, it was often conflicts/corruption in the .htaccess file (articles always mention re: permalinks and regenerating your .htaccess file)

4) Made a backup of .htaccess file on remote site.

5) Made a new .htaccess file and copied all the correct info back into it (I noticed there were some old PHP commands in there related to my old site, and possibly some duplicate rules from old SSL plugins etc. I also noticed my webhost had recently added some new rules during a server migration that perhaps were causing some conflict with existing duplicate rules). Saved file back to remote site via FTP.

6) The missing Featured Image, Categories, Tags etc sidebar items all reappeared!

Not sure why the WP core selectively turned off only these three things due to an htaccess file, but the experts surely will... perhaps there's some failsafe that can be added to prevent this. :-)

I saw this issue in many forums and all the posts were closed even though not totally solved. I hope whoever has this issue comes across this solution**

#5 follow-up: @mrfoxtalbot
13 months ago

I have not run into this issue personally, but it sounds like it is happening to quite a few people.

Those of you experimenting this regularly, could you please open the inspector in your browser and share any errors you see in the console there, @jhmonroe @stevenjaycohen & @Kuuuzya?

@jhmonroe, you mentioned having seen this problem discussed elsewhere, could you please share a link to these conversation to help connect the dots? Thank you!

#6 in reply to: ↑ 5 ; follow-up: @stevenjaycohen
13 months ago

Replying to mrfoxtalbot:

could you please open the inspector in your browser and share any errors you see in the console there, @jhmonroe @stevenjaycohen & @Kuuuzya?

Hey there, my report was 12 months ago, and the workaround I included fixed the issue for me. So there is nothing in my console at this time that I could supply to aid in diagnosis. I can say that no upgrades since v5.9 have caused the issue to recur.

#7 @stevenjaycohen
13 months ago

Since the title of this issue includes v5.9, I'd like to suggest branching off the v6.1.1 into a new issue while keeping the 2 issues related.

Just because the presenting symptom is the same, we should not assume that the underlying cause is the same :)

#8 in reply to: ↑ 6 @jhmonroe
4 months ago

FWIW, I'm still getting this issue intermittently in v6.3.2 when I open certain pages, Featured Image is missing in the WP admin and also does not appear in three dots > preferences > panels > Document settings > *featured image*

Some pages it will show up, others it won't. It's notable that when it does load, it's one of the last things to load on the page after everything else. All the other admin items will load in the sidebar, then template switches from "default template" to "pages" (the block theme site editor version of this), "slug" quickly switches to "URL", author loads, move to trash loads, and featured image area loads. Template & Slug visibly switching leads me to believe the core is running thru classic theme checks first, then loading block theme versions of these items. For some reason the block theme version of Featured image is the last thing to load on the page. Also the fact that other posters mention adding a blank index.php file solves their issue. This makes is seem like the core is still preferring classic theme requirements sporadically depending how quickly the page loads and performs all it's checks.

I made a video so everyone can see the order things load here. When Featured Image doesn't load, it's as if the last step in this video just doesn't happen.
https://www.dropbox.com/s/axbtsuzed6slhbb/reload-featured-image.mov?dl=0

Other mentions (addressing index.php, styles.css, jquery, wp-includes, re-installing core, themes, plugins, etc):
https://core.trac.wordpress.org/ticket/55019 (this ticket)
https://core.trac.wordpress.org/ticket/52855
https://wordpress.org/support/topic/missing-the-upload-featured-image-option-after-update-the-wp-5-9/ (this one is really detailed)
https://wordpress.org/support/topic/theme-support-for-post-thumbnails-stopped-working-after-upgrading-to-wp-5-7/
https://wordpress.org/support/topic/featured-image-feature-has-vanished/
https://github.com/WordPress/gutenberg/issues/45836
https://wordpress.org/support/topic/featured-image-field-not-showing-in-the-admin-panel/
https://wordpress.org/support/topic/no-categories-and-featured-image-can-set/
https://stackoverflow.com/questions/66563202/theme-support-for-post-thumbnails-stopped-working-after-upgrading-to-wordpress-5
https://stackoverflow.com/questions/67423437/featured-image-of-wordpress-doesnt-appear-in-admin/71261080#71261080
and many more!:
https://wordpress.org/search/featured+image+missing/

Replying to stevenjaycohen:

Replying to mrfoxtalbot:

could you please open the inspector in your browser and share any errors you see in the console there, @jhmonroe @stevenjaycohen & @Kuuuzya?

Hey there, my report was 12 months ago, and the workaround I included fixed the issue for me. So there is nothing in my console at this time that I could supply to aid in diagnosis. I can say that no upgrades since v5.9 have caused the issue to recur.

Last edited 4 months ago by jhmonroe (previous) (diff)
Note: See TracTickets for help on using tickets.