Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#5508 closed defect (bug) (fixed)

names displayed 2 or 3 times when you edit user's profile

Reported by: jopa Owned by:
Milestone: 2.5 Priority: low
Severity: normal Version: 2.3.1
Component: Administration Keywords: 2nd-opinion has-patch
Focuses: Cc:


Hello everyone,

I am new here and i've just installed wordpress and i am really happy with the features and its simplicity.

After spending some hours searching and touching things here and there - trying to create my personal blog - i found that when you go to edit a user's profile, in the field: "Display name publicly as: " it shows in the list the username 2 times. If you dont touch the Nickname field then it shows 3 times the same username.

Its not something critical and probably it doesnt create any problem for wordpress in general, however i've just noticed that and thought that it could be a good idea to inform you about it.

Sorry if that bug has been mentioned before but i checked your system and i didnt find anything.

See the screenshots for more details.

Problem checked with both firefox and opera browsers.


Attachments (3)

wordpress2.jpg (130.9 KB) - added by jopa 8 years ago.
wordpress1.jpg (131.3 KB) - added by jopa 8 years ago.
unique-display-name-suggestions.diff (2.0 KB) - added by nbachiyski 8 years ago.

Download all attachments as: .zip

Change History (17)

8 years ago

8 years ago

#1 @jopa
8 years ago

  • Milestone changed from 2.5 to 2.3.2
  • Type changed from task to defect

#2 @DD32
8 years ago

  • Keywords 2nd-opinion needs-patch added
  • Milestone changed from 2.3.2 to 2.5

The reason for multiple versions being shown would be the Username/Real Name/Nickname entered being identical.
I'm not too sure why when the Real name is empty it displays the username though.. So it might be something else there.

A Possibility would be to only show unique values, However, With the current form, If you change the details that the display name relied upon, I believe it'll change that too...

Milestone to 2.5 as it doesnt have a patch.

#3 follow-up: @jopa
8 years ago

Maybe it feels the "empty" fields with the username and because of that it makes it to be displayed 2 and 3 times?

#4 in reply to: ↑ 3 @jopa
8 years ago

i mean fills* not feels sorry.

#5 @jopa
8 years ago

just to inform you that this problem exists in the new version of wordpress too.

I've just installed wordpress v2.3.2 and i've checked it and again the names are displayed 2 or 3 times.


#6 @darkdragon
8 years ago

  • Milestone 2.6 deleted
  • Resolution set to invalid
  • Status changed from new to closed

This is expected behavior since WordPress uses the user's username for each of the three fields. It is likely to inform the user, albeit counter-intuitive to some users.

Thinking about it, if you checked to see if username, nickname, and display name are the same and only display one, then a new user might not conceive that if they changed any of those that the values in the drop down will also change.

It might seem like a bug, but it was helpful to me and I'm sure it is helpful to others to realize the true intent of the drop down.

See wp_insert_user() for more details.

#7 @nbachiyski
8 years ago

  • Keywords has-patch added; needs-patch removed
  • Milestone set to 2.5
  • Resolution invalid deleted
  • Status changed from closed to reopened

darkdragon, it may be helpful for you, because you just see how the things work under the hood and see the point. However, for most of the users it is just irritating.

Here is a patch from me.

#8 @darkdragon
8 years ago

Fine by me, my point was that unless there is a patch, there is no point arguing over something that is by all means intentional.

By the way, you forgot one. There is also: lastname, space, firstname.

Patch looks awesome.

#9 @nbachiyski
8 years ago

  • Priority changed from normal to low

Updated the patch with the missing combination, thanks.

#10 @ryan
8 years ago

The same needs to be done for profile.php. We should see if user-edit.php and profile.php can be combined. Maybe they can share an edit-user-form.php template.

#11 @ryan
8 years ago

(In [6652]) Eliminate dupes from display name list. Props nbachiyski. see #5508

#12 @ryan
8 years ago

Committed the user-edit.php patch. Leaving open for profile.php.

#13 @jopa
8 years ago


darkdragon maybe for some advanced users is usefull, but unfortunately for newbie users like me that seems strange.. and make us believe that wordpress is not working properly.

Glad to see that this ticket is reopened.. Wordpress is a great blog software and it would be nice everything to work perfectly..

Thanks nbachiyski for the patch.

I second ryan's comment about combining the user-edit.php and profile.php

#14 @nbachiyski
8 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

The merge has its own ticket -- #5736, so I will close this one.

Note: See TracTickets for help on using tickets.