Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 9 months ago

#55125 closed defect (bug) (reported-upstream)

HTML tags in post titles are gone when editing existing posts

Reported by: rotti's profile rotti Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9
Component: Editor Keywords:
Focuses: Cc:

Description

Hello,

since the update to wordpress 5.9 we've detected some strange behavior, when editing existing posts, that contains HTML-Tags in their post title.
The problem is, when editing the post, the HTML-Tags in the post title, are not displayed in the editor. The tags are just gone.

Steps to reproduce:

  1. Create a new post with HTML-Tags in the title for example: "<em>This is my title</em>"
  2. Save and publish the post with this title
  3. Go back to the "All posts" list
  4. Post is correctly displayed with "<em>This is my title</em>" in the list (also the "Quick Edit"-Functionality correctly displays the <em>-Tags)
  5. Edit the post
  6. The post title lost the <em>-Tags
  7. Change the post title to "This is my title 2"
  8. Save the post
  9. <em>-Tags are totally gone, even in the "All posts" list.

The behavior came through wordpress 5.9, i’ve quickly tested the issue with a complete new and empty 5.8.3 version and a complete new and empty 5.9 version. In the 5.8.3 this behavior is not reproducable, in the 5.9 it is. I’ve used the official docker images for that wordpress:5.8.3 and wordpress:latest, completely new setup without any plugins or custom themes.

I've already created a topic in the forums, where i got the info to create a bug ticket here:
https://wordpress.org/support/topic/html-tags-in-post-titles-are-gone-when-editing-existing-posts/

If it is necessary i can also provide some screenshots, but i think the problem should be clear.

Best regards
Christoph

Change History (7)

#1 @azouamauriac
2 years ago

Hi there welcome to the trac! thank you for the report. I'm able to reproduce issue and I think this is related Gutenberg so would you like to report the issue here https://github.com/WordPress/gutenberg/issues/new/choose ?

Thank you.

#2 @rotti
2 years ago

Hi @azouamauriac,
thanks for this information. I've created a github issue at https://github.com/WordPress/gutenberg/issues/38668 in the Gutenberg project.

#3 @skorasaurus
2 years ago

closing since this has been reported upstream on the gutenberg issue tracker.

#4 @skorasaurus
2 years ago

  • Resolution set to reported-upstream
  • Status changed from new to closed

#5 @desrosj
2 years ago

  • Milestone Awaiting Review deleted

#6 @costdev
2 years ago

Related: #55803

#7 @ironprogrammer
9 months ago

#59037 was marked as a duplicate.

Note: See TracTickets for help on using tickets.