Make WordPress Core

Opened 2 years ago

Closed 2 months ago

#55180 closed defect (bug) (wontfix)

Twenty Seventeen: Comments not showing up on the frontpage

Reported by: robertghetau's profile robertghetau Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9
Component: Bundled Theme Keywords: close
Focuses: Cc:

Description

Hi there,

I'm not able to find any further information on this, but it looks like the comments aren't showing up on a static homepage with Twenty Seventeen.

I have tested this with the latest update of WordPress(5.9) and the last version of the theme.

Steps to reproduce

  1. Switch theme to twenty seventeen
  2. Enable "Allow comments" within the discussion tab on the sidebar on the homepage.
  3. Check the page and search for the comments area.

Original request: https://github.com/Automattic/themes/issues/5545

If this is intended, I found this as a potential workaround: https://wordpress.stackexchange.com/questions/268305/display-comments-on-homepage-of-twenty-seventeen-theme

Change History (4)

#1 @sabernhardt
2 years ago

  • Component changed from General to Bundled Theme

#2 @sabernhardt
12 months ago

  • Keywords 2nd-opinion added

I did not find an explanation for the absence of comments on the front page in the original Twenty Seventeen repository, so this may be unintentional.

I am nervous about changing the template file now, when most people who want comments probably have already worked around it in a child theme or they have chosen a different theme. The front page might be open for comments without the site owner realizing (or wanting) that.

Maybe an admin notice could appear when updating the theme to call attention to the new behavior.

#3 @karmatosed
2 months ago

  • Keywords close added; 2nd-opinion removed

I am also nervous about changing the template file and even adding an admin notice. My recommendation for now would be to close this, but I am happy to reconsider if others require that. Thank you for the collaboration so far.

#4 @karmatosed
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thank you everyone for your collaboration, I am going to progress through and close this now.

Note: See TracTickets for help on using tickets.