Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#55221 closed defect (bug) (duplicate)

Feature image does not load media library in correct view.

Reported by: jhall_3rd's profile jhall_3rd Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.8.2
Component: Media Keywords:
Focuses: Cc:

Description

Clicking the feature image of any post that has one set will open the media library with "uploads attached to this post" chosen - though the select menu itself will display "images" Navigating away via the sel menu and then back to "images" corrects the issue.

1- edit post in CLASSIC EDITOR
2- open a post that has a featured image.
3- click "edit or update"
4- media lib opens in view "uploads attached to post" yet the selector will show "images" - the correct option should be "images" since user is wishing to select a new one or edit the existing.

Attachments (1)

featured image bug 480p.mov (8.2 MB) - added by jhall_3rd 2 years ago.
video showing steps to reproduce bug

Change History (5)

@jhall_3rd
2 years ago

video showing steps to reproduce bug

This ticket was mentioned in Slack in #core-test by hellofromtonya. View the logs.


2 years ago

#2 @hellofromTonya
2 years ago

  • Component changed from Editor to Media
  • Keywords needs-testing added

Hello @jhall_3rd 👋,

Welcome to WordPress Core's Trac! Thank you for the ticket and providing steps to reproduce and a video showing the issue you are reporting - well done 👏⭐

The Test Team is currently testing to attempt to reproduce the reported issue. Test Reports will follow.

I've also adjusted some info in the ticket for better discoverable.

#3 @Boniu91
2 years ago

Not able to reproduce it on the newest version.

Test Report

Env

  • WordPress 5.9.1
  • Chrome 99.0.4844.51
  • Windows 10
  • Theme: Twenty Twenty One

Steps to test

  1. Add new post with featured image using Classic Editor
  2. Click on the Featured Image in order to edit it
  3. Correct view with all uploaded media is displayed

#4 @hellofromTonya
2 years ago

  • Keywords needs-testing removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Following up:
This issue was reported in #53765 and a fix shipped in 5.9 with [52384] changeset.

I'll close this ticket as a duplicate.

@jhall_3rd upgrading to 5.9.1 should resolve the issue you're experiencing. If no, please re-open the ticket for further investigation. Thank you!

Note: See TracTickets for help on using tickets.