Make WordPress Core

Opened 2 years ago

Closed 4 weeks ago

#55264 closed defect (bug) (worksforme)

Twenty Twenty-Two Looks Bad on Firefox

Reported by: aichedvs's profile aichedvs Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.9
Component: Bundled Theme Keywords: reporter-feedback close
Focuses: Cc:

Description

There are two issues in twenty twenty-two that I have. Unfortunately, the 1.1 release has not fixed them. Others have reported the same issues to the support forum.

I am using a staging site to test and customize the new theme for one of my sites. I am about ready to go public with it but for these issues.

The customized theme looks good with the Google Chrome and Microsoft Edge browsers, and on my iPhone. But with Firefox the header navigation bar is always expanded, and the page content appears in plain text. I have made no customization to the fonts or to the navigation bar. The problem must be the way Firefox renders the core code.

A less critical issue is that on Chrome and Edge, pages load in plain text before quickly becoming formatted. This is not a disabling issue, as is the Firefox issue, but it is annoying.

Where should I go from here? I don’t think I should go online when I can’t deliver a decent looking site to Firefox users.

Change History (9)

#1 @joyously
2 years ago

What version is your Firefox?
This sounds exactly like the report for the .org redesign: https://github.com/WordPress/wporg-mu-plugins/issues/159#issuecomment-1050976561

#2 follow-up: @aichedvs
2 years ago

I had Firefox 48.0.1, but when I went to find this out it automatically updated to 56.0 (32 bit). The problem remained with this version. The release notes said this came out in September 2017. Not believing this could be the latest, I manually downloaded and installed Firefox again. Now I have 97.0.1 (64 bit) and the important issue has been corrected. The site now looks good on Firefox too.

But the other issue I reported, with the pages loading first in plain text before quickly becoming formatted, is also occurring with Firefox (as well as Chrome and Edge). This I consider an annoyance rather than a show stopper, but it should be addressed by the WordPress/Gutenberg folks.

Thank you for your help.

#3 follow-up: @joyously
2 years ago

I hope you don't think that your problem is solved. It might look OK to you now, using the latest Firefox, but your visitors might not have the latest Firefox.

#4 in reply to: ↑ 2 ; follow-up: @audrasjb
2 years ago

  • Keywords reporter-feedback added; needs-patch removed

Hello and welcome to WordPress Core Trac @aichedvs,

Replying to aichedvs:

But the other issue I reported, with the pages loading first in plain text before quickly becoming formatted, is also occurring with Firefox (as well as Chrome and Edge). This I consider an annoyance rather than a show stopper, but it should be addressed by the WordPress/Gutenberg folks.

Does it also occur on a fresh install without any plugin? I can't reproduce the issue on my side in any browser.

#5 in reply to: ↑ 3 @aichedvs
2 years ago

Replying to joyously:

I hope you don't think that your problem is solved. It might look OK to you now, using the latest Firefox, but your visitors might not have the latest Firefox.

This is something I'll have to live with. There is no way I can guarantee backward compatibility with every browser. This site is a church, we get only double or low triple digit views in an average day, and I have no idea how many are using Firefox.

#6 in reply to: ↑ 4 ; follow-up: @aichedvs
2 years ago

Replying to audrasjb:

Hello and welcome to WordPress Core Trac @aichedvs,

Replying to aichedvs:

But the other issue I reported, with the pages loading first in plain text before quickly becoming formatted, is also occurring with Firefox (as well as Chrome and Edge). This I consider an annoyance rather than a show stopper, but it should be addressed by the WordPress/Gutenberg folks.

Does it also occur on a fresh install without any plugin? I can't reproduce the issue on my side in any browser.

Removing plugins does not help. The same issue has been posted by others in the Twenty Twenty-Two Support Forum with the title "Website content flickers when loaded".

#7 in reply to: ↑ 6 @aichedvs
2 years ago

Replying to aichedvs:

Replying to audrasjb:

Hello and welcome to WordPress Core Trac @aichedvs,

Replying to aichedvs:

But the other issue I reported, with the pages loading first in plain text before quickly becoming formatted, is also occurring with Firefox (as well as Chrome and Edge). This I consider an annoyance rather than a show stopper, but it should be addressed by the WordPress/Gutenberg folks.

Does it also occur on a fresh install without any plugin? I can't reproduce the issue on my side in any browser.

Removing plugins does not help. The same issue has been posted by others in the Twenty Twenty-Two Support Forum with the title "Website content flickers when loaded".

The site has been updated to WP 5.9.1 and the flicker problem appears to have gone away. The site now looks good on the three browsers (Chrome, Edge, and Firefox), and the iPhone.

#8 @karmatosed
4 weeks ago

  • Keywords close added

If I am to believe this issue it seems like what has been an issue before is now resolved @aichedvs. Based on that I am going to mark this as a candidate for closing and we can always review if it is not the case it has been resolved. Thank you everyone for the collaboration.

#9 @karmatosed
4 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

For now, I am going to close this. Thank you everyone we can always have a new ticket if this is an issue still.

Note: See TracTickets for help on using tickets.