Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#55313 closed defect (bug) (invalid)

Fix PHP Plugin

Reported by: ppatel821's profile ppatel821 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9.1
Component: General Keywords: close
Focuses: Cc:

Description

Since the most recent Word Press update, I am receiving multiple errors on my site:

Deprecated: Required parameter $args follows optional parameter $depth in /home4/parasand/public_html/wp-content/themes/grandwedding/lib/menu.lib.php on line 22

Deprecated: Required parameter $output follows optional parameter $depth in /home4/parasand/public_html/wp-content/themes/grandwedding/lib/menu.lib.php on line 22

Warning: Cannot modify header information - headers already sent by (output started at /home4/parasand/public_html/wp-content/themes/grandwedding/lib/menu.lib.php:22) in /home4/parasand/public_html/wp-includes/pluggable.php on line 1355

Warning: Cannot modify header information - headers already sent by (output started at /home4/parasand/public_html/wp-content/themes/grandwedding/lib/menu.lib.php:22) in /home4/parasand/public_html/wp-includes/pluggable.php on line 1358

Change History (3)

#1 @joyously
2 years ago

The problem is in the theme. Due to the deprecation notice being output, the "headers already sent" warning is output.
Fix the theme, and turn off the error display so this isn't a problem later.

#2 @azouamauriac
2 years ago

  • Keywords close added
  • Severity changed from blocker to normal

#3 @jrf
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

As @joyously correctly surmised, this is a problem with your theme, not with WordPress Core. Please report this to the theme author.

Also note that the issue IMO is unrelated to the WordPress upgrade you mention you did, but is in actual fact related to a PHP upgrade I suspect you've done (or your host did). This is a new deprecation as of PHP 8.0.

Note: See TracTickets for help on using tickets.