Make WordPress Core

Opened 2 years ago

Last modified 21 months ago

#55368 reopened defect (bug)

Handle ajax failure when doing actions on themes/plugins

Reported by: mirkolofio's profile mirkolofio Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 5.9.2
Component: Administration Keywords:
Focuses: javascript, administration, ui-copy Cc:

Description

When maintenance mode is active or the server is unresponsive for any reason, there are some ui issues in ajax-related messages like:

  • When trying to delete a plugin: "Deleting..." forever. No error shown.
  • When trying to enable auto-updates on a plugin: "Enabling..." forever. "The request could not be completed" error is shown. Same for disabling.
  • When trying to delete a theme: "Deletion failed: undefined" error shown.
  • When trying to enable a theme: "Enabling..." forever. "The request could not be completed." error shown. Same for disabling.

Check the screenshots attached below.

I tried to stay short in title description but I'm not sure it's 100% clear.

Attachments (4)

Screenshot 2022-03-11 at 06.02.39.png (3.6 KB) - added by mirkolofio 2 years ago.
Plugin delete failure
Screenshot 2022-03-11 at 06.02.02.png (9.6 KB) - added by mirkolofio 2 years ago.
Plugin enable auto-updates failure
Screenshot 2022-03-11 at 06.01.15.png (4.6 KB) - added by mirkolofio 2 years ago.
Theme delete failure
Screenshot 2022-03-11 at 06.00.57.png (16.1 KB) - added by mirkolofio 2 years ago.
Theme enable failure

Download all attachments as: .zip

Change History (9)

@mirkolofio
2 years ago

Plugin delete failure

@mirkolofio
2 years ago

Plugin enable auto-updates failure

@mirkolofio
2 years ago

Theme delete failure

@mirkolofio
2 years ago

Theme enable failure

#1 in reply to: ↑ description @mirkolofio
2 years ago

  • When trying to delete a plugin: "Deleting..." forever. No error shown.

There an error there: "Deletion failed: Briefly unavailable for scheduled maintenance. Check back in a minute."

It's on the top of the page, I missed it.

#2 @azouamauriac
2 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Hello there, welcome to WordPress's trac! Thanks for the report, this seems to be an expected behavior.

If you think I'm wrong feel free to reopen the ticket and may be explain more deeply what's the bug.

Thanks.

#3 @mirkolofio
2 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Reopening this. It's not expected at all, let me better explain.

Example on Plugin enable auto-updates failure

Current behaviour:

  • Button switched to "Deleting..." forever
  • Error message shown: "The request could not be completed"

Expected behavior:

  • Button switched to "Deleting..."
  • Error message should be: "The request could not be completed. Please retry."
  • The button should be switched back to "Delete"

Another example on Theme delete failure

Current behaviour:

  • Error message shown "Deletion failed: undefined"

Expected behaviour:

  • At least we don't want to show "undefined" for sure.

And so on...

#4 @mirkolofio
2 years ago

Since maintenance is frequently due to a plugin/theme/core update in progress and it's usually a matter of seconds, the messages should be clear enough to permit the user to retry just a second later.

Please not that if you click on the "Deleting..." button once again it works, it's not a matter of feature though, it's just some bad/confusing UI/UX.

Last edited 2 years ago by mirkolofio (previous) (diff)

#5 @sabernhardt
21 months ago

  • Component changed from Text Changes to Administration
Note: See TracTickets for help on using tickets.