Make WordPress Core

Opened 2 years ago

Last modified 2 years ago

#55385 new defect (bug)

Error in Search

Reported by: himanshushokhanda's profile himanshushokhanda Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords: reporter-feedback
Focuses: Cc:

Description

Hi Support,

When we are searching any keyword which start from .profile it send the backend normal post and page search to the frontend not found. Instead it should stay on same page and show not found.

For example please search this www.profile.com and it will send you to frontend.

Can you please advise why it is happening ?

Regards,
Himanshu

Change History (2)

#1 @costdev
2 years ago

  • Keywords reporter-feedback added

Hi @himanshushokhanda, welcome to Trac!

I can't seem to reproduce this issue.

Env

WordPress: 5.9.2
OS: Linux
Browser: Chrome
Theme: Twenty-Twenty Two
Plugins: None activated

Steps to reproduce the issue

  1. Navigate to Posts > All Posts.
  2. Search for www.profile.com. If brought to the frontend, the issue has been reproduced.
  1. Navigate to Pages > All Pages.
  2. Search for www.profile.com. If brought to the frontend, the issue has been reproduced.

Results

  • The page refreshed and displayed search results as expected. Issue not reproduced.

@himanshushokhanda, can you tell us:

  • Are the above steps to reproduce the issue correct?
  • What version of WordPress are you using?
  • Have you tried disabling plugins in case one of these is causing an issue when searching posts?

#2 @erengy
2 years ago

This is likely related to Apache's ModSecurity module rather than WordPress. .profile is a restricted filename at OWASP ModSecurity Core Rule Set.

See also: https://serverfault.com/questions/932614/apache-issue-with-profile-in-the-url

Note: See TracTickets for help on using tickets.