Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 7 months ago

#55412 closed defect (bug) (invalid)

Language "German (Austria)" outputs html lang incorrectly as "de-DE" not "de-AT" since WordPress version 5.9

Reported by: simjost's profile simjost Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Focuses: Cc:

Description

Since version 5.9 including 5.9.1 and 5.9.2 the lang attribute in the html tag for the language/translation "German (Austria)" is incorrectly output as "de-DE". This would be correct for plain German, but for the region of Austria it should be "de-AT".

Downgrading to 5.8.4 fixes the issue.
Other languages/translations like "German (Swiss)" and "English (UK)" and "English (US)" don't have the same issue.

Change History (3)

#1 @ocean90
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed
  • Version 5.9 deleted

Hi @simjost, this attribute is a translatable string and I think a recent import of the de_DE translations has changed this accidentally. I have updated the translation and also this one.
The new language pack with the updated translations should be available soon. cc: @pputzer

Marking as invalid as it's not an issue with WordPress core.

#2 @simjost
2 years ago

@ocean90 thank you for the information, clarification and the quick action.
The updated translations are available for WordPress version 5.9.2 (not below though).

#3 @swissspidy
7 months ago

#59985 was marked as a duplicate.

Note: See TracTickets for help on using tickets.