Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#55436 closed defect (bug) (invalid)

Image Galleries are NOT displayed properly on SAFARI

Reported by: learnamo's profile learnamo Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

WordPress image galleries are not displayed properly on the latest version of Safari released a week ago.

Here is a screenshot of an image gallery on my website: https://www.icloud.com/iclouddrive/0a5zJXeBHnspN46JrJ80kJDHQ#1._Gallery_-_Working_fine

Here is a screenshot of the same image gallery when you visit my website using the latest version of Safari: https://www.icloud.com/iclouddrive/01dPiwpfzrqvqKwucQy-9k-Kw#2._Gallery_-_Broken

Change History (6)

#1 follow-up: @vijayhardaha
2 years ago

Hey,
I am unable to reproduce the issue https://snipboard.io/Fpct4y.jpg

I am using Safari Version 15.4 (17613.1.17.1.6) & macOs 12.3

You might be having a cache issue or something. Try Private window on safari.

#2 in reply to: ↑ 1 @learnamo
2 years ago

Replying to vijayhardaha:

Hey,
I am unable to reproduce the issue https://snipboard.io/Fpct4y.jpg

I am using Safari Version 15.4 (17613.1.17.1.6) & macOs 12.3

You might be having a cache issue or something. Try Private window on safari.

Hi @vijayhardaha,

Thank you for your reply!

The issue does not occur all the time. However, I invite you to visit the following pages with Chrome and Safari, so that you can spot the differences in the galleries:

https://learnamo.com

https://learnamo.com/lezioni/

Best wishes,
Graziana

#3 @vijayhardaha
2 years ago

Hey @learnamo,

I checked the other pages, At the start, I didn't find anything, then I refresh the quickly so many time then I encountered this issue https://snipboard.io/47rZsa.jpg

Here link and image HTML is rendered, but the image source is showing 1px x 1px I also checked the network tab to check if that specific file is in the rendering list, so it wasn't there.

To me, it looks like a Jetpack Lazy load issue. It's Ok most of the time but it randomly produces this behavior.

You can try to disable the lazy load option from jetpack and then If you're able to see the same issue.

You can also ask about it in Jetpack Support Forum to understand the cache on this kind of behavior
https://wordpress.org/support/plugin/jetpack/

#4 follow-up: @costdev
2 years ago

  • Component changed from General to Editor
  • Keywords reporter-feedback added
  • Severity changed from critical to normal
  • Version 5.9.2 deleted

@vijayhardaha, thanks for investigating this issue!

Hi @learnamo, welcome to Trac!

Please try disabling the Jetpack lazy load option as @vijayhardaha suggested and let us know if the gallery displays as expected.

If the issue still occurs, please open a new issue on the Gutenberg repository and comment here with a link to the issue.


  • Adding the reporter-feedback keyword as this issue currently requires a response from @learnamo.
  • The Version parameter is used to indicate which version of WordPress Core introduced an issue. As this isn't verified as a WordPress Core issue, I'll reset the Version.
Last edited 2 years ago by costdev (previous) (diff)

#5 in reply to: ↑ 4 @learnamo
2 years ago

You guys were right!

I turned lazy loading off and everything was just fine! I have already contacted Jetpack to signal this bug.

Thank you guys for your help! You are amazing!

Replying to costdev:

@vijayhardaha, thanks for investigating this issue!

Hi @learnamo, welcome to Trac!

Please try disabling the Jetpack lazy load option as @vijayhardaha suggested and let us know if the gallery displays as expected.

If the issue still occurs, please open a new issue on the Gutenberg repository and comment here with a link to the issue.


  • Adding the reporter-feedback keyword as this issue currently requires a response from @learnamo.
  • The Version parameter is used to indicate which version of WordPress Core introduced an issue. As this isn't verified as a WordPress Core issue, I'll reset the Version.

#6 @costdev
2 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

@learnamo Great to hear! I'll close this ticket as invalid now that we know it's an issue with a plugin.

Note: See TracTickets for help on using tickets.