Make WordPress Core

Opened 23 months ago

Closed 23 months ago

Last modified 23 months ago

#55527 closed defect (bug) (duplicate)

<em></em> disappears from post titles when post (in 'editing' view) is refreshed + post titles lose italics formatting when changes made

Reported by: altfgcom's profile altfgcom Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9.2
Component: Editor Keywords: close
Focuses: Cc:

Description

Hello,

There's a bug affecting post titles following WordPress' Josephine upgrade.

We were hoping that someone else was going to report it, but it's been a couple of months and the issue is still there even after the most recent bug-fixing releases.

This is what happens:

Post Title: "<em>Gone with the Wind</em> won 10 Oscars"

Once the post is saved AND refreshed (of course, on the editor's side), the "markers" <em></em> disappear from view.

The title now reads:

"Gone with the Wind won 10 Oscars"

The only way to verify GWTW is still in italics is to click on "view post," so we can see the live page.

That's *not* how it was before Josephine, and obviously that's not how it should be.

There's more:

Again, once the post has been saved AND refreshed, the title reads:

"Gone with the Wind won 10 Oscars" (The italicized GWTW can be seen only in the live post)

Now, let's say we decide to change the post title to:

"Gone with the Wind won 10 Oscars in 1939"

Once we do that, the italics ALSO disappear from the live post even though we haven't made any changes to the words "Gone with the Wind."

In order to restore the italics, we have to re-enter <em></em> around "Gone with the Wind."

And once again, after the post is saved/refreshed, the markers <em></em> disappear *again* from the editor's view. (Though GWTW remains italicized on the live post.)

That shouldn't happen. Could you please fix this double issue?

<em></em> should always be visible at our end. And the italics format should never disappear from the title (on the live post) just because we edited it.

We're using the latest version of WordPress.

The issue continued after we deactivated all plugins and used the WP theme.

Your assistance would be much appreciated.

If you need any further explanations/clarifications, please contact us at editor@….

Thank you.

Change History (6)

#1 @azouamauriac
23 months ago

  • Component changed from General to Editor
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #55371.

Hi welcome to core trac, thanks for the report.

We already trac the bug here.

Hope it will be fixed early.

#2 @altfgcom
23 months ago

Hello,

Thanks for the reply, but is it really the exact same issue?

We've never seen the error message "The editor has encountered an unexpected error."

We can continue editing our posts even when there are html markers in the title. They just disappear from view once the page is refreshed (and from the "live version" of the title itself [in "view post"] if we make changes to it).

Anyhow, I see that you're a moderator/bug fixer(?), as you've closed the ticket I opened yesterday.

So you're aware that this - variation of the 55371 issue? - is happening. That's why I'm not reopening the ticket.

#3 @azouamauriac
23 months ago

Hello @altfgcom thanks for your comment, you're right, my previous comment wasn't very clear,

In fact, here is the real duplicated ticket: #55125 , but the one I targeted as duplicated was the most recent. They both have the same cause, I worked on both that's why I just used #55371 instead #55125, in my mind they are same. As you can see this PR aims to fix both together.

If I missed something feel free to reopen the ticket. Thanks again.

Last edited 23 months ago by azouamauriac (previous) (diff)

#4 follow-up: @altfgcom
23 months ago

Just wanted to say thanks for the reply.

I see that the issues we're having - html markers disappear from title after post refreshed, italics disappear from title once changes are made to it - are pretty much discussed there.

The curious thing is, someone there seems to know what the cause is.

Wondering why it hasn't been fixed yet (including yesterday's WP update).

Anyhow, thanks again.

Version 0, edited 23 months ago by altfgcom (next)

#5 in reply to: ↑ 4 @azouamauriac
23 months ago

  • Keywords close added

Replying to altfgcom:

The curious thing is, someone there seems to know what the cause is.

Wondering why it hasn't been fixed yet (including yesterday's WP update).

Only few people are accustomed to the component used at this part of the code, that's why it is hard to fix it.

Anyhow, thank you again.

You're welcome.

#6 @desrosj
23 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.