WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#5554 closed defect (bug) (duplicate)

Special danish characters get stripped.

Reported by: soerenbc Owned by: westi
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords: needs-patch
Focuses: Cc:

Description

I create a page containing one ore more of the danish special characters (æøå).

I then start to edit that page. Then the "View >>" link points to a 404. The page name gets stripped of the special characters.

Example:
http://compadre.dk/blog/%C3%B8nskeseddel/

How to reproduce:
Create a page called ÆØÅæøå.
Edit that page.
Click the "View>>" link (located just right of all the buttons.)

Kind regards
Søren

Change History (6)

comment:1 darkdragon6 years ago

  • Component changed from General to i18n

comment:2 darkdragon6 years ago

You're problem is quite complex, given the nature of i18n.

I have questions:

  1. What browser are you using?
  2. What language support does your browser have?

It is possible your browser is trying to translate your URL into something more machine/english readable and is causing WordPress to hiccup.

It is also possible WordPress is stripping your characters, which it should not do.

comment:3 westi6 years ago

  • Owner changed from anonymous to westi
  • Status changed from new to assigned

This sounds like a dupe of #4739.

Which isn't easy to solve :-(

comment:4 mrmist5 years ago

  • Keywords needs-patch added

Also related #5554 #4739 vaguely #6106 #1762 #4328 #6973 #3206

comment:5 Denis-de-Bernardy5 years ago

  • Resolution set to duplicate
  • Status changed from assigned to closed

Merging into #9591.

comment:6 Denis-de-Bernardy5 years ago

  • Milestone 2.9 deleted
Note: See TracTickets for help on using tickets.