Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#55602 closed defect (bug) (duplicate)

theme.json custom variables with letter and number next to eachother gets converted to letter {dash} number in the css vars HTML output

Reported by: cbaldelomar's profile cbaldelomar Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9.3
Component: General Keywords:
Focuses: Cc:

Description

In theme.json file, version 2, the following custom entry

"heading-font-size-h1": "var(--cp-vars-heading-font-size-h1)",

renders in an HTML document:

--wp--custom--heading-font-size-h-1: var(--cp-vars-heading-font-size-h1);

This use to not be the case, and was a breaking change for plugins and themes that use h1 in their CSS vars instead of the changed h-1.

Change History (2)

#1 @joyously
2 years ago

  • Focuses coding-standards removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #54953.

#2 @desrosj
2 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.