Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#55621 closed enhancement (duplicate)

Prime user meta in User REST API endpoint

Reported by: spacedmonkey's profile spacedmonkey Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7
Component: REST API Keywords: has-patch
Focuses: performance Cc:

Description

Ensure that user meta is primed in User REST API endpoint. Without being primed, this results in a single query per user in a /wp/v2/users query. See screenshot.

Attachments (2)

Screenshot 2022-04-26 at 15.38.12.png (122.2 KB) - added by spacedmonkey 2 years ago.
Before
Screenshot 2022-04-26 at 15.39.56.png (127.0 KB) - added by spacedmonkey 2 years ago.
After

Download all attachments as: .zip

Change History (13)

This ticket was mentioned in PR #2632 on WordPress/wordpress-develop by spacedmonkey.


2 years ago
#1

  • Keywords has-patch added

#2 @spacedmonkey
2 years ago

It is worth noting that in WP_MS_Users_List_Table and WP_MS_Users_List_Table pass the 'fields' => 'all_with_meta',.

This ticket was mentioned in Slack in #hosting-community by javier. View the logs.


2 years ago

spacedmonkey commented on PR #2632:


2 years ago
#4

@peterwilsoncc I agree. I think we should maybe focus on this - https://github.com/WordPress/wordpress-develop/pull/2614

This ticket was mentioned in Slack in #hosting-community by javier. View the logs.


2 years ago

This ticket was mentioned in Slack in #hosting-community by jadonn. View the logs.


2 years ago

#7 @spacedmonkey
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #55594.

#8 @spacedmonkey
2 years ago

  • Milestone set to 6.1

This ticket was mentioned in Slack in #hosting-community by javier. View the logs.


2 years ago

This ticket was mentioned in Slack in #hosting-community by jadonn. View the logs.


2 years ago

#11 @TimothyBlynJacobs
2 years ago

  • Milestone 6.1 deleted

Clearing the milestone since this has been closed as a duplicate.

Note: See TracTickets for help on using tickets.