Make WordPress Core

Opened 10 years ago

Closed 9 years ago

#5563 closed enhancement (duplicate)

Plugins Integrated Within Themes are Not Disabled When The Theme Is Disabled

Reported by: keithdsouza Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Template Keywords:
Focuses: Cc:


By Default few themes come with integrated plugins or modules. Once theme is disabled the default plugins for the themes are still active.

This is not a hassle but those plugins become redundant once the theme has been deactivated so the plugins integrated with themes should be deactivated accordingly.

Suggestion is to create better management of theme based plugins and core plugins, by default the the both should not be clubbed together.


Change History (2)

#1 @ionfish
10 years ago

  • Priority changed from high to normal
  • Severity changed from major to normal
  • Type changed from defect to enhancement

This strikes me as the responsibility of theme/plugin authors; the deactivation hooks are there for them to use, after all.

#2 @DD32
9 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

IMO, Its the responsibility of the author to make sure the plugins are deactivated.

See also #7795(Activate and Deactivate Theme hooks). Its currently possible for themes to detect deactivations (switch_theme hook) so i'm closing this as a duplicate of the above.

Note: See TracTickets for help on using tickets.