Make WordPress Core

Opened 2 years ago

Closed 10 months ago

#55684 closed defect (bug) (invalid)

CPU load memory full on PHP 8.1 – WordPress posting new post

Reported by: attosoftonline's profile attosoftonline Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.9.3
Component: TinyMCE Keywords: needs-testing php81
Focuses: Cc:

Description

I noticed that if there is wordpress version 5.9.3, at least, and if the server is running php 8.1, every time I post something, the hosting resources reach the upper limit. cpu becomes full. with a php 7.4 this does not happen.

Please, fix it!

Change History (2)

#1 @spacedmonkey
12 months ago

  • Keywords php81 added

#2 @hellofromTonya
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hello @attosoftonline,

Welcome to WordPress Core's Trac! Sorry for the delay in responding to your ticket.

Running out of memory can be caused by web server setup, memory constant, and/or something in the site that is consuming too much memory.

I suggest the following:

  • Check the memory settings on your website.

Here's a Support document to help. See the "Allowed memory size exhausted" section.

You can also check with your hosting provider.

  • Deactivate all plugins. Does the CPU issue go away?

If yes, then one or more of the plugins is part of the problem. To identify which one or ones, reactivate them one-by-one and recheck the CPU usage. You an open an issue with the plugin(s) causing the issue.

  • Check with your hosting company. Have you reached to your hosting provider for them to check the site, logs, PHP memory setting, etc for running on PHP 8.1?

I suspect the root cause is something in server where more memory is needed. The Support article linked above provides you with help on how to increase the memory.

As this does not appear to be a WordPress Core issue, I'm closing this ticket.

However, if the problem persists after doing the steps above and it appears it might be a Core issue, then please reopen this ticket and share as much information as you can including steps of how to reproduce the issue and all of the above checks and findings.

Note: See TracTickets for help on using tickets.