Make WordPress Core

Opened 2 years ago

Closed 4 months ago

#55730 closed defect (bug) (duplicate)

URL slug generation issue with Hindi language

Reported by: haribonda's profile haribonda Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.7.2
Component: Permalinks Keywords:
Focuses: Cc:

Description

hello, I do not know how to report a bug in WordPress, this is my first time starting a ticket regarding an issue.

i have made post using Hindi langue but the slug is not getting generated correctly few of the characters are missing

post title is हम तेलुगु से कितना प्यार करते हैं but the slug is missing word करते हैं

https://domain.com/हम-तेलुगु-से-कितना-प्यार-क/

you can reproduce this by trying to create the post using above words

Change History (4)

#1 @SergeyBiryukov
2 years ago

  • Component changed from General to Permalinks

#2 @sabernhardt
21 months ago

Hi and welcome to Trac! Thanks for the report!

This seems to be caused by the 200-character limit (related: #10483).

The encoded form of that example post slug is 195 characters:
%e0%a4%b9%e0%a4%ae-%e0%a4%a4%e0%a5%87%e0%a4%b2%e0%a5%81%e0%a4%97%e0%a5%81-%e0%a4%b8%e0%a5%87-%e0%a4%95%e0%a4%bf%e0%a4%a4%e0%a4%a8%e0%a4%be-%e0%a4%aa%e0%a5%8d%e0%a4%af%e0%a4%be%e0%a4%b0-%e0%a4%95

And the next character in the title would be another 9 encoded characters:
%e0%a4%b0

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


5 months ago

#4 @sabernhardt
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This probably should be a duplicate of #10483. If I am wrong, please reopen the ticket.

Note: See TracTickets for help on using tickets.