Make WordPress Core

#55735 closed defect (bug) (duplicate)

WordPress子分类的固定链接存在Bug

Reported by: jimmyhuang's profile jimmyhuang Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9.3
Component: Canonical Keywords:
Focuses: Cc:

Description

使用WP过程中发现子分类的固定链接存在一些Bug。搭建了个测试站,还是存在同样问题。
具体来说,假设父级分类是:uncategorized,子分类是:test。子分类正确的访问地址应该是:
example.com/category/uncategorized/test
但我发现把地址中的uncategorized重命名为其他内容也能访问子分类test,正常应该返回404页面。

测试地址:https://sandbox.jimmyhuang.pp.ua/category/uncategorized/test
Bug地址:https://sandbox.jimmyhuang.pp.ua/category/0000/test

WordPress Version 5.9.3
Themes:Twenty Twenty-Two Version: 1.1
CDN:Cloudflare

Change History (2)

#1 in reply to: ↑ description @jimmyhuang
22 months ago

Replying to jimmyhuang:

使用WP过程中发现子分类的固定链接存在一些Bug。搭建了个测试站,还是存在同样问题。
具体来说,假设父级分类是:uncategorized,子分类是:test。子分类正确的访问地址应该是:
example.com/category/uncategorized/test
但我发现把地址中的uncategorized重命名为其他内容也能访问子分类test,正常应该返回404页面。

测试地址:https://sandbox.jimmyhuang.pp.ua/category/uncategorized/test
Bug地址:https://sandbox.jimmyhuang.pp.ua/category/0000/test

WordPress Version 5.9.3
Themes:Twenty Twenty-Two Version: 1.1
CDN:Cloudflare

Google Translate
During the use of WP, some bugs were found in the permalinks of subcategories. I built a test station and still have the same problem.
Specifically, suppose the parent category is: uncategorized and the sub-category is: test. The correct access address for the subcategory should be:
example.com/category/uncategorized/test
But I found that renaming uncategorized in the address to other content can also access the subcategory test, which should normally return a 404 page.
Test address: https://sandbox.jimmyhuang.pp.ua/category/uncategorized/test
Bug address: https://sandbox.jimmyhuang.pp.ua/category/0000/test
WordPress Version 5.9.3
Themes:Twenty Twenty-Two Version: 1.1
CDN: Cloudflare

#2 @dd32
22 months ago

  • Component changed from General to Canonical
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @jimmyhuang and welcome to Trac.

I've reviewed your bug report, and it appears it's the same as #18734

Thank you for your submission, I'm closing this as a duplicate of #18734 to keep discussion in the same place.

Note: See TracTickets for help on using tickets.