Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#55752 closed defect (bug) (fixed)

site-editor.php query params disappear

Reported by: grantmkin's profile grantmkin Owned by: peterwilsoncc's profile peterwilsoncc
Milestone: 6.0 Priority: normal
Severity: normal Version: 6.0
Component: Editor Keywords: has-patch fixed-major commit dev-reviewed
Focuses: Cc:

Description (last modified by SergeyBiryukov)

The Site editor supports adding query params, like styles=open to open the the Global Styles panel when the editor is loaded. These params are disappearing.

It looks like the changes in [53093] might be the cause. cc @gziolo

To reproduce

  • Visit /wp-admin/site-editor.php, close the sidebar to set its state to closed
  • Visit /wp-admin/site-editor.php?styles=open

Expected

  • The Global Styles panel is open

Actual

  • The Global styles panel does not open

Change History (11)

This ticket was mentioned in Slack in #core-editor by grantmkin. View the logs.


2 years ago

#2 @SergeyBiryukov
2 years ago

  • Description modified (diff)
  • Milestone changed from Awaiting Review to 6.0

Hi there, welcome back to WordPress Trac! Thanks for the ticket.

Moving to the milestone for visibility.

#3 @gziolo
2 years ago

@Mamaduka, are you able to help with this one?

This ticket was mentioned in PR #2727 on WordPress/wordpress-develop by Mamaduka.


2 years ago
#4

  • Keywords has-patch added

PR fixes the issue when query parameters are removed on Site Editor homepage redirection.

Trac ticket: https://core.trac.wordpress.org/ticket/55752

#5 @peterwilsoncc
2 years ago

  • Owner set to peterwilsoncc
  • Resolution set to fixed
  • Status changed from new to closed

In 53413:

Site Editor: Include style parameter in home template redirect.

When redirecting the site editor to the home template include the style querystring parameter if it is set. This ensures the style panel opens if the user expects it.

Props grantmkin, mamaduka, peterwilsoncc.
Fixes #55752.

#7 @peterwilsoncc
2 years ago

  • Keywords dev-feedback fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for merging in to the 6.0 branch upon a second committer's approval.

There was a report in the Gutenberg repo of problems on mobile due to responsive logic, this commit does not fix that issue. It only fixes the issue on desktop.

#8 @gziolo
2 years ago

  • Keywords commit added

[53413] looks good for backporting to 6.0.

There was a report in the Gutenberg repo of problems on mobile due to responsive logic, this commit does not fix that issue.

Yes, that's a bigger problem because editing the template usually requires definitely more CPU than editing a page/post content.

This ticket was mentioned in Slack in #core by costdev. View the logs.


2 years ago

#10 @peterwilsoncc
2 years ago

  • Keywords dev-reviewed added; dev-feedback removed

Marking dev-reviewed per comment above.

#11 @peterwilsoncc
2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 53415:

Site Editor: Include style parameter in home template redirect.

When redirecting the site editor to the home template include the style querystring parameter if it is set. This ensures the style panel opens if the user expects it.

Props grantmkin, mamaduka, peterwilsoncc, gziolo.
Merges [53413] to the 6.0 branch.
Fixes #55752.

Note: See TracTickets for help on using tickets.