Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 23 months ago

#55754 closed task (blessed) (fixed)

Bump bundled theme versions for 6.0.0 release

Reported by: peterwilsoncc's profile peterwilsoncc Owned by: peterwilsoncc's profile peterwilsoncc
Milestone: 6.0 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch has-unit-tests dev-reviewed fixed-major
Focuses: Cc:

Description

All bundled themes from 2010 to 2022 will need a version bump for the 6.0 release.

Change History (19)

#1 @peterwilsoncc
2 years ago

  • Type changed from defect (bug) to task (blessed)

#3 @peterwilsoncc
2 years ago

I've linked a pull request to this issue. I still have a couple of themes to test before it's ready.

#4 @peterwilsoncc
2 years ago

The linked pull request is ready for review.

I've bumped the theme number of all the bundled themes as they've all had some work over the last few months. All of them have had improvements made to the translator comments so it will be good to get those in to the project.

When reviewing the pull request please take a look at the themes directory and let me know if there are any asset version bumps that I have missed.

A few of them get the theme version from wp_get_theme() so not all themes that have had asset changes need a version bump.

If you're a committer and notice something needs work, feel free to push to my branch. Especially if I am asleep.

This ticket was mentioned in Slack in #core by costdev. View the logs.


2 years ago

mehedifoysal commented on PR #2726:


2 years ago
#6

I checked all of them and look perfect to me

peterwilsoncc commented on PR #2726:


2 years ago
#7

@desrosj @costdev I think I've caught all of the _tested up to_ bumps that are required now. Thanks for catching that.

It looks like several other styles and scripts did not have their versions bumped. I had always just assumed that the theme version was used, but seems that for older default themes, that's not the case.

@peterwilsoncc what do you think about changing all of these date versions to be accurate now? Or, we could just open a follow up ticket.

I reviewed the commits in the `wp-content/themes` directory and manually bumped the assets that had changed.

I think using the theme version is a good idea but let's use a follow up ticket. For themes with build tools it might we worth using wp-scripts to generate the version as it will be more performant. But let's discuss that there.

This ticket was mentioned in PR #2733 on WordPress/wordpress-develop by peterwilsoncc.


2 years ago
#8

  • Keywords has-unit-tests added

#9 @peterwilsoncc
2 years ago

  • Owner set to peterwilsoncc
  • Resolution set to fixed
  • Status changed from new to closed

In 53416:

Themes: Accept valid block themes.

Updates theme validation to accept block themes. This replaces the requirement for an index.php with a requirement for either an index.php, /templates/index.html or the deprecated /block-templates/index.html.

Validation is updated for theme uploads, within WP_Theme::__construct and validate_current_theme().

A block theme using the deprecated file structure is now included in the unit tests.

Props peterwilsoncc, sergeybiryukov, hellofromtonya, costdev, azaozz, gziolo, FlorianBrinkmann, Boniu91, aristath, poena, audrasjb.
Fixes #55754.

#10 @peterwilsoncc
2 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening because I used the wrong ticket reference in the commit above.

#12 @peterwilsoncc
2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 53418:

Bundled themes: Bump versions for WordPress 6.0 release.

Bump bundled theme version numbers in preparation for the WordPress 6.0 release. Each theme's _tested up to_ file header has been increased to indicate WordPress 6.0 support.

The new version numbers are:

  • Twenty Ten: 3.7
  • Twenty Eleven: 4.1
  • Twenty Twelve: 3.7
  • Twenty Thirteen*: 3.7
  • Twenty Fourteen: 3.4
  • Twenty Fifteen*: 3.2
  • Twenty Sixteen*: 2.7
  • Twenty Seventeen*: 3.0
  • Twenty Nineteen: 2.3
  • Twenty Twenty: 2.0
  • Twenty Twenty-One: 1.6

An asterisk indicates the theme includes assets requiring a manual version bump, this is set to the reverse date format of the release day: 20220524.

Follow up to [53286] in which the Twenty Twenty-Two theme version was bumped to 1.2.

Props peterwilsoncc, desrosj, costdev, mehedi890.
Fixes #55754.

#13 @peterwilsoncc
2 years ago

  • Keywords dev-feedback fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for merging to the 6.0 branch pending another committers sign-off.

#14 @SergeyBiryukov
2 years ago

  • Keywords dev-reviewed added; dev-feedback removed

[53418] looks good to backport.

For reference, just noting that #55682 was the correct ticket for [53416].

#15 @SergeyBiryukov
2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 53423:

Bundled themes: Bump versions for WordPress 6.0 release.

Bump bundled theme version numbers in preparation for the WordPress 6.0 release. Each theme's _tested up to_ file header has been increased to indicate WordPress 6.0 support.

The new version numbers are:

  • Twenty Ten: 3.7
  • Twenty Eleven: 4.1
  • Twenty Twelve: 3.7
  • Twenty Thirteen*: 3.7
  • Twenty Fourteen: 3.4
  • Twenty Fifteen*: 3.2
  • Twenty Sixteen*: 2.7
  • Twenty Seventeen*: 3.0
  • Twenty Nineteen: 2.3
  • Twenty Twenty: 2.0
  • Twenty Twenty-One: 1.6

An asterisk indicates the theme includes assets requiring a manual version bump, this is set to the reverse date format of the release day: 20220524.

Follow up to [53286] in which the Twenty Twenty-Two theme version was bumped to 1.2.

Props peterwilsoncc, desrosj, costdev, mehedi890.
Merges [53418] to the 6.0 branch.
Fixes #55754.

#17 @desrosj
2 years ago

While preparing the theme updates for release, I noticed that Twenty Ten did not actually have any changes to the actual source code during the 6.0 cycle.

It looks like adding the Changelog link to the readme.txt file was missed last time around. This can be updated independent of an actual theme update that is deployed to potentially 1.2 million+ sites (total number of sites with Twenty Ten installed).

Post-release, let's un-bump the version for that theme and get the readme.txt updated on .org.

#18 @peterwilsoncc
2 years ago

In 53448:

Budled themes: Revert the Twenty Ten theme version to 3.6.

No functional changes were made to Twenty Ten during the WordPress 6.0 release cycle so the theme version bump is not needed. The "tested up to" header change is maintained.

Follow up to and partial revert of [53418].

Props desrosj, ravipatel, costdev.
Fixes #55810.
See #55754.

#19 @SergeyBiryukov
23 months ago

In 53648:

Bundled Themes: Revert the Twenty Ten theme version to 3.6.

No functional changes were made to Twenty Ten during the WordPress 6.0 release cycle so the theme version bump is not needed. The "Tested up to" header change is maintained.

Follow-up to and partial revert of [53418].

Props desrosj, ravipatel, costdev, peterwilsoncc.
Merges [53448] to the 6.0 branch.
See #55810, #55754.

Note: See TracTickets for help on using tickets.