WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#5577 closed defect (bug) (fixed)

Switching between HTML and visiual views destroys some table markup

Reported by: mdawaffe Owned by:
Milestone: 2.5 Priority: normal
Severity: normal Version:
Component: General Keywords: JS has-patch commit
Focuses: Cc:

Description

To reproduce:

  1. Enter the following into HTML view (formerly known as "Code view").
    <table border="1" width="100%">
    	<tr>
    		<th align="center">Centered</th>
    		<th>Heading 1</th>
    		<th>Heading 2</th>
    	</tr>
    
    	<tr bgcolor="#cccccc">
    		<td><b>Bold</b></td>
    		<td>Foo</td>
    		<td>Bar</td>
    	</tr>
    </table>
    
  1. Switch to Visual view.
  2. Switch back to HTML view.
  3. Notice that the second TR is gone.

This is caused by a bad regex in the JS that converts between the two views.

Patch attached.

Attachments (1)

5577.diff (1.8 KB) - added by mdawaffe 8 years ago.

Download all attachments as: .zip

Change History (3)

@mdawaffe8 years ago

comment:1 @mdawaffe8 years ago

  • Keywords has-patch commit added

comment:2 @ryan8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6547]) Don't bust table markup when switching between visual and html. Props mdawaffe. fixes #5577

Note: See TracTickets for help on using tickets.