Make WordPress Core

#55781 closed defect (bug) (duplicate)

SQL_CALC_FOUND_ROWS and SQL_CALC_FOUND_ROWS are deprecated

Reported by: jdorner's profile jdorner Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9.3
Component: Database Keywords:
Focuses: Cc:

Description

According to https://dev.mysql.com/doc/refman/8.0/en/information-functions.html#function_found-rows

The SQL_CALC_FOUND_ROWS query modifier and accompanying FOUND_ROWS() function are deprecated as of MySQL 8.0.17; expect them to be removed in a future version of MySQL.

These functions do not appear to be deprecated in MariaDB.

These are used in the following methods:
WP_Query->get_posts()
WP_Comment_Query->get_comment_ids()
WP_Network_Query->get_network_ids()
WP_Site_Query->get_site_ids()
WP_User_Query->prepare_query()

Change History (2)

#1 @craigfrancis
22 months ago

Hi John, thanks for reporting... can you check if this issue is covered by #47280?

#2 @desrosj
22 months ago

  • Component changed from Posts, Post Types to Database
  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #47280.

This does look like a duplicate report to me. @jdorner feel free to reopen if that's not the case.

Note: See TracTickets for help on using tickets.